I purchased a new Android Phone which is pre-installed with V2.1 Eclair. At least once in a day phone gets dead (At this stage I cannot press and any key or unable to make/receive calls). The only option I have at this stage is to remove and re-insert my phone's battery.

I googled all the day for it and found many people says that the issue is with wifi. But I never enabled/used Wifi before. This happens more than once in a day. I took my phone to service centre and they reinstalled OS but still the issue persists. I strongly believe its issue with s/w. Anybody help me get rid of this issue.

Thanks in advance!

  • What type of phone?
    – Chance
    Mar 22, 2012 at 16:53
  • @Chance - Its MicroMax A60. Mar 22, 2012 at 16:59
  • You don't need to remove & re-insert battery.. try pressing & holding power button for 10 seconds & release..
    – iOS
    Mar 22, 2012 at 17:02
  • @SachinShekhar - I tried that before. But no use. Mar 22, 2012 at 17:09
  • Have you tried using a different battery? Low chance this will help, but I'd give that a shot just to rule out the possibility of a defective battery.
    – Chahk
    Mar 23, 2012 at 12:38

1 Answer 1


I would seriously consider rooting and installing a custom ROM. I've installed custom ROMs which gave me the SOD issue - my point is that I believe SOD is in fact tied to what ROM (whether stock or custom) you are running. This question details various things on rooting. For specific directions on rooting and custom ROM for your phone model, you'll have to do a search here for that or on Google.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .