0

I am trying to unlock a Sony Xperia X that was locked to a Canadian carrier (Freedom). The previous owner sold me the phone unlocked (SIM) but he failed to unlock the bootloader.

I followed the instructions here and realized that the rooting status states that boot-locker unlock is set to no.

I also got the developer options enabled and made sure that the OEM unlocking is set to true and USB debugging set to true.

Next I ran adb devices and my device shows up.

enter image description here

However I ran fast-boot devices after starting the phone in bootloader mode (Volume Down + insert USB cable), it doesn't recognize any device.

I am wondering: is there any way I can get around Sony's restrictive Boot-loader unlock setting and get root on my phone? I desperately need to get rid of some bloatware.

  • Have you installed the fastboot drivers? Windows requires different drivers for ADB and fastboot mode. Boot to bootloader connect the device and check the device manager for unknown devices. – Robert Mar 18 at 8:03
  • So this is what I did, after connecting my phone and firing up a CMD window ,I looked for fastboot devices and it showed nothing. Out of curiosity I rebooted into bootloader using fastboot command ( think it was fastboot reboot bootloader ) and it booted my phone in the bootloader mode. This should confirm that I have the right fastboot drivers installed right ? – Allan Varkey Mar 18 at 13:58
  • The only real confirmation that fastboot drivers are working correctly is that fastboot devices lists your device. Boot to bootloader and search for Android Bootloader interface or something like this. See also: wtfandroid.com/fix-fastboot-device-not-recognised-problem – Robert Mar 18 at 14:10
  • @Robert Thank you. i will give this a shot when i get home. i wouldn't be surprised if the fastboot drivers are not installed properly – Allan Varkey Mar 18 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.