1

This is about data corruption on android . The primary issue relates to bad blocks / clusters and it happens to be android platform. So this is a super user and NOT android enthusiast question. answers to this question will apply to ANY corrupt card whether PC or android. So its thoughtless to tag this is android

This is a Sandisk 128gb ( leave this link - its not an ad .Specific card indicates other paras like memory channels , write speed etc card I am using on an Android Nougat device.

This is the 2nd time the card had corruption issues. 1st one I bought got Write Locked . Present Replacement was provided
The card has a lot of bad clusters. 2 things got me to sniff this :

  • whatsApp directory ( which had a bind to whatsapp dir on internal ) : the image directory can no longer be written to
  • Phone randomly reboots and next time exFat partition is not mounted ( I used app2sd and partitioned the card to ext4 10gb to link my apps and rest if exfat )

ran a chkdksk on windows 7 and it would autoterminate on initial run & persisting on running gave me repeated message "# cluster moved for file " ( cant recollect exact verbiage ). It could Never complete it but aborted with the message . "corruption found in card "

questions :

  • How do I know if there is logical or physical bad cluster. Any tool / test ?
    Here's something I did - that made me think logical. I removed the images directory ( which was write locked and so as long as the binding was on , whatsapp images could not be downloaded. Once I switched off folder mount tool that enforced this, it would work ) after moving the contents to dir2 and renamed dir2 to original dir. after del the original dir. Now for sometime whatsapp binding would work and the same problem came again . So I tend to think but need confirmation.
  • I am thinking of salvaging the contents of exfat partition and then format partition and instead create 2 ext4 partitions ( or FF2S. Tell me which is better) . One is for less write apps. My photos etc here and other smaller one just for whatsapp and then copy back contents to relevant partitions.

If I do this. There is no out of box support for ext4 partitions for android ( isn't ,pl confirm) ? how do I auto mount without 3rd party utils ( fstab ? ) How do I auto mount the extra ext4 - fstab ? Will this help avoid the above problem ?

  • While I still have the corrupt block partition is there ANY other tool that will run till the end and identify all bad blocks so they can be kept aside .I tried aparted for android which runs fsck ( exFat sub ) and the report came normal in < 1 min .
  • 1
    Some errors are marginal, not hard or foreseeable, so you cannot assume anything. Our advice on SD card errors have always been the same : Get a new one, nobody can fix a bad card. – harrymc Mar 22 at 10:45
  • Are you sure the SDcard is genuine? I strongly recommend you to test it before using it. For example using the Windows tool H2Testw it uses the full sdcard and checks it it really has the size it claims to have. – Robert Mar 22 at 12:56
  • I am aware of fakes. Yep this is tested by H2testW - before I used it I ran the brute test – user1874594 Mar 22 at 14:09
  • Sometimes the specific card ( usually depending on price ) will have extremely fine wiring, this is the case with many large storage device's on small physical devices like USB Memory Sticks & SD Cards... The card actually has an overheating protection to stop the wires from becoming damaged, This will stop Read & Write access to the device temporarily to allow cooling... This seems to cause a R/W Error for a computer... Instead of waiting for access, it immediately registers the current sector it was scanning as unusable... You need to follow the manufacturer instructions carefully... 5mb p/w – Gadget Guru Mar 22 at 20:31
  • Have you tried BadBlocks on an Android... @Unknown:/ $ badblocks Usage: badblocks [-b block_size] [-i input_file] [-o output_file] [-svwnf] [-c blocks_at_once] [-d delay_factor_between_reads] [-e max_bad_blocks] [-p num_passes] [-t test_pattern [-t test_pattern [...]]] device [last_block [first_block]]....... OR FIX THE DRIVE WITH CHECK DISK ... chkdsk -Drive -f .... If a nondestructive -f won't fix it... try a destructive fix with -r (it implies -f ) chkdsk -r – Gadget Guru Mar 22 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.