2

If I enter the Wi-Fi settings of Android-x86 (currently v8.1-r1) inside VirtualBox (currently v6.0.4) and turn it on, why does it just immediately get turned off?

Some Android apps try to find devices inside the network so it's essential (e.g. if you want to use Chromecast and iRobot Home).

enter image description here

1

If you're running Android within a VM, I suspect the VM software is not allowing the Android VM to interact with your WiFi hardware directly, meaning that Android does not actually see that there is any hardware available for accessing WiFi. If you check your internet connection on the Android VM, does it show you're connected to the internet via ethernet?

There may be a way in VirtualBox's settings to give the VM direct access to your WiFi chip, but I highly doubt that would work based on the nature of running Android via a VM on desktop or laptop hardware.

| improve this answer | |
  • Where can I check what you asked? Also, according to online searches, it seems even if you give direct access to Wi-Fi, the VM will still see it as Ethernet. – LWC Mar 29 '19 at 16:31
  • 1
    It would be in the VirtualBox settings somewhere (I don't use VB, so I'm not sure where exactly). Like you said, though, I'm pretty sure it will only bridge the PC's wifi connection so that Android sees it is a hard line connection (ethernet). – phishfi Mar 29 '19 at 17:41
  • I've answered you as a full answer. – LWC Mar 29 '19 at 18:21
1

Turns out according to the official docs, "VirtualBox provides up to eight virtual PCI Ethernet cards", which means no Wi-Fi card is available to emulate. Even if the host provides Internet to the guest via Wi-Fi, all the guest sees is Ethernet.

But if VirtualBox is incapable of it, then how does Genymotion bypass it?

Major update: thanks for using this very question as motivation, as of 2 days ago Android-x86 simulates WiFi on its own!

Virtual Wi-Fi in Androix-x86

| improve this answer | |
0

Simple just install it on Virtual Box software, after you install android on VirtualBox, go to setting and change the network setting just like this:

enter image description here

enter image description here

enter image description here enter image description here

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.