1

tl;dr: After 2+ months of using my Kodi 18.1 started to get a complete wako, by playing different movie than description, image, scoring etc. says. For example, it plays "The Hunt for the Red October" when I select "Zootopia".

Tried everything (rebuilding library, removing and adding the source), all for nothing.


My SMB/FTP server structure:

  • Movies:
    • Animated
    • Drama
    • Political
    • ...

I have added two sources to my Kodi 18.1:

  • "Animated" --> SMB/Movies/Animated,
  • "Movies" --> SMB/Movies.

So, in fact, all animated movies can be listed / accessible through both sources (if that matters).

Now, in Kodi I am selecting first source ("Animated") and browse to the end of list ("Zootopia"). I see everything perfectly: description, movie poster, ratings, year, actors everything is correct.

The only problem is that when I start playing it, "The Hunt for the Red October" plays.

This problem occurs for most of the database entries in the "Animated" source (but not for all). For example "Jason Bourne" places when "Shrek" is excepted etc.

"Animated" folder in SMB/FTP is accessible both through "Animated" and "Movies" source in Kodi, but not the otherwise. I.e., if you open up the "Animated" source in Kodi, no movies from i.e. "Drama", "Political", "Action" etc. folders in SMB/FTP are accessible AFAIK.

And yet, Kodi gets wako and plays movies from different source than use is actually browsing.

Filenames are "purified" manually by me and files are named matching patterns "English title (Year)" exactly. So there is no way Kodi can get confused:

  • it claims that it is going to play movie "Zootopia (2006)" in "Animated",
  • it actually plays file SMB/Political/The Hunt for the Red October (1992).mp4.

I have tried everything that came to my mind. I have cleared the database (but this seems to be only deleting references to non-existing files, it does not recreate / verify references to existing files). I have removed "Animated" source and added it again. I have used "Look for a new content"-like options. All for nothing.

I have noticed that after removing the source and adding it back, Kodi still keeps information on what was watch and upon which time watching of given movie stop, i.e. still offers to "restart" watching from given position. So, it clearly suggests that removing and adding the same source again does not clear any cache or stuff like this.

Any idea what I can do in this situation except for throwing Kodi to hell and start looking for some alternative player for my Android-TV home player?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.