I bought a low-budget china no-brand phone brand: 'WELCOME' model: 'P20 Pro' , and some things seem a little odd.

Before using the phone, I did a factory reset. When I first turned it on before the reset, the phone looked fresh, but there was a user looged in on which had the name Phenix (I didn't know at that point, that there was also this app called Phenix).

There's a custom kernel on my device although I bought it as new. I noticed some minor translation errors which I have never seen on my other android devices (only few, but they were obvious enough to catch the eye). This was actually the thing that made me check the kernel version.

There are several system apps, that look odd to me, e.g. Android Easter Egg, Phenix (which seems to be some Asian social platform or a salesTracker-app.

There are a lot more from which I don't know what they do, but I don't like how permissions are set (the lack of transparency is a thing I hate about modern operation systems like Android).

Does someone know some good lists or websites where to find information on them? Do I really need to root my handy to remove Phenix, which seems to be an active process, that can't be removed for longer than some seconds? I like the hardware very much, but I do want to know what it is doing and I really don't like the idea of running processes on my device which share information over the network. If needed I can provide a full list of my Apps (active, installed, deactived, running).

I already tried to deactivate some by myself, and most seemed to break Google Play Store, so that this app wouldn't work correctly.

Another odd thing is the Google Play Store itself, though the phone seems to be quite powerful, it freezes a lot especially when I click on Install. Many apps won't even install, and one app I installed had asian letters mixed with latin letters under the icon though the game is translated into proper english and I do remember that I had the game before on another device, and there weren't this asian symbols.

Can someone give me some advice on how to judge the situation?

Are there more advanced analysis-tools for android that could help to figure out what is running on my phone?

I heared that rooting a device is not recommended anymore, so I'd like not to do that if possible.

Update 30.03.2019

As my phone now, only some days after aquiring it, tries to install apps without me even touching it at that time, and showing ads even though I have already deinstalled all apps in question I downloaded (apart from those standard apps I already know long enough so they shouldn't be responsible), I will go the way and flash a custom rom on it. I think there is far too much odd behaviour for an android-system so freshly set up.

I will update this post once I have done so (might take some days, got some other stuff to do atm)


Can someone provide me with a bug report (developer mode) on a freshly factory-reset Android 8.1? Saw some interesting things in mine and would like to compare with a bug report from a phone that's not a no-brander from Asia.

Update #2:

found com.adups.fota on my phone and some other stuff that stays on factory reset. will definitely put a custom rom on it next week. Have not even finished reading the bugreport. There is also an app called Systemaktualisierung (german), translated: System Update, which cannot be deinstalled in usermode, but can be deactivated. It refers to com.adups.fota. Ads still show up, I receive no more bug reports and sadly I can't install anti-virus software. I definitely not recommend byuing china-phones if you don't want to head straight here or to xda xD

Phenix and all apps that refer to com.cooee.whatever (like phenix, WeatherClock..app and so on) seem to be infected regarding to what other found with malwarebytes and co.

Appended: Apps I consider harmful:

  • System Update com.adups.fota* UpgradeSys com.fw.upgrade*
  • Fota Provider com.adups.fota* packages starting with com.cooee.*

  • com.mediatek ? Warning: mediatek seems to be needed for the phone to run, do not remove if you don't know what you are doing. - MediaTek seems to provide the chipset, and from what I read, the firmware might be infected. Most infected china phones seem to run on MediaTek.

  • com.zhuoyi.* Not showing up in the GUI
  • Facebook com.facebook.* why? because it shouldn't even be there, not showing up in the GUI!
  • twitter com.twitter* See Facebook. Yes. I dislike both anyway.
  • FreeTouch com.ibao.c this one was registered as admin
  • com.higua.changesalecount I think this one might be salesTracker
  • com.freeme*
  • com.kpsh* seems to belong to com.cooee* and is not listed at packages, but at the processes


malwarebyte-scan detected this:

  • Google Serv (sadly I did think this belonged to Google
  • Clean Weather Clock (com.cooee)
  • UpgradeSys (com.fota)
  • Phenix (com.cooee.phenix)

and two on my SD-card:

  • Adware.Moblick*

At the moment I am not sure if I even got the real Google Play Store or whether it is a fake one. The icon is green, not like the colorful one. I thought that this was due to the custom rom. As stated above, it doesn't behave quite as I am used to it behave, so the alarm flag is raised there still. As I want to discover the infected phone a little more before I fix it, I'd like to find out, how to discover what Store I really got.

--- Update ---

Packages that needed pm uninstall -k --user 0 $PACKAGE because they threw


after pm uninstall $PACKAGE

  • com.thihaayekyaw.frozenkeyboard
  • com.ibao.c
  • com.higua.changesalecount
  • com.fw.upgrade.sysoper
  • com.zhuoyi.demo.application
  • com.adups.fota
  • com.android.fmradio
  • com.adups.fota.sysoper
  • com.android.egg
  • com.cooee.widget.samweatherclock
  • com.cooee.widget.ClearWeatherClock
  • com.freeme.motionrecognition

After deleting ClearWeatherClock I ran into a looping prompt that prevented me from using the device. You need to reboot the device, which meant on this model that I had to press the powerbutton for almost a minute since anything else wouldn't work.

Package I am not sure if it is safe to delete

  • com.cooee.phenix

You can hide it with pm hide leaving you without a desktop manager.

Packages that could be deleted with a simple pm uninstall without root

  • com.facebook.katana
  • com.freeme.video
  • com.whatsapp
  • com.google.android.youtube
  • com.twitter.android

Update April 29:

Using the phone after diabling all these packages did work for some days. Just like the first time I put the phone in use it worked something similar to fine for the first week, which means the motion sensor didn't recognize some horizontal line about a centimeter thick in the middle of the screen and completely failed on rotation plus the battery percentage went a complete mess (staying at 100% very long, then falling rapidly); but apart from that the phone worked well and the battery endured much longer. Sadly, some hours ago the phone decided to not recognize my unlock pattern anymore and I could see on the lock screen that abo sms started again, just like last time. At this point, where even the motion recognition seems to have some dependency on obvious bloatware, I am no longer willing to try to make any use of this phone. Correct me if I am wrong and missed a thing.

Pressing Volume UP and Power brings me to some non-standard-android menu that allows me to select recovery, fastboot and normal; recovery leads to an android warning saying "No command", whereas fastboot leads to a freezing screen. The normal-option works.

I eventually managed to get into the Factory mode. It is possible to enter Test mode, which was quite interesting to see, but no factory reset option here, either. Some tests are poorly implemented from what I can tell by the output. Sadly had to leave it as the key test was impossible to pass or go back as the device has no home button but requires it to be pressed. Still trying to reconstruct how I got there.

Randomly pressing Vol Up and Vol Down during the "No command"-screen led me to the factory reset menu (some more options). Can't tell the exact kreystrokes though. Glad it is possible. Phone has all packages back I removed with adb uninstall, as expected. The motionrecognition is still the same mess though. At least I could figure out now that is has seemingly complete random offset to any direction. Don't know if that has anything to do with what I did with it or if it would have happened anyway.

Will make some wireshark tests later.

  • If you want a UI for listing the apps you can use App Inspector – Robert Mar 28 '19 at 19:47
  • Funnily I have problems with installing apps, most of them don't get installed. Actually I'd prefer some real wiki on it, if there is, like the ones there are for Linux and Windows. Haven't yet found a really good one on Android. – Melissa Loos Mar 30 '19 at 18:16

I don't think you need to go the root route if all you're trying to do is remove some apps. For finding out what every one of those apps does, I don't think there is a site/service that can really give you a good amount of info on all of them.

However, if you're interested in removing apps you know to be useless, there is one option that is recoverable and relatively straight-forward:

You can install ADB (the Android Debug Bridge - it's very simple to install), then access your device from Windows/Mac/Linux and run a few commands against the phone.

adb shell pm disable-user --user 0 PackageName

is a command that will disable the package so that your phone's system cannot see the application anymore and none of the app can load into memory on the device. This is a very simple and useful way to remove system apps that won't permanently change your device. If you remove an app and later realize that you really need it, you can use this command to get it re-installed:

adb shell pm enable PackageName

For further instructions, check out this XDA article.

  • java.lang.SecurityException: Permission Denial: attempt to change component state from pid=12252, uid=2000, package uid=1000 when trying to disable a package – Melissa Loos Apr 4 '19 at 11:19
  • Try with just disable instead of "disable-user". – phishfi Apr 4 '19 at 11:21
  • remains the same error – Melissa Loos Apr 4 '19 at 11:21
  • 1|shell@Smartphone:/ $ pm uninstall com.higua.changesalecount Failure [DELETE_FAILED_INTERNAL_ERROR] so this happens when I just want to uninstall. I managed to uninstall com.facebook.katana , so the uninstall command seems to work :/ – Melissa Loos Apr 4 '19 at 11:24
  • 1
    pm hide $PACKAGE did the job in this case. – Melissa Loos Apr 4 '19 at 13:06

My go to for gaining knowledge of a particular phone type is to head to XDA and see what people who have it are saying, there also advice on things you'd be interested in such as system apps, and what some users have removed with success and not. Its not a comprehensive solution, because it does depend upon the number of users feeding into the forum.

With regards to the Google Play Store, it does sound as though the operating system is perhaps interfering with the Play Store. Couldn't say for sure. But that odd behaviour you have mentioned does stick in my mind as software based.

In terms of rooting, I appreciate you are not wanting to explore that path, I'd suggest it as a viable option if it works for you, (something the XDA developers lot will be able to point you in the right direction of), because then you have the option of flashing a custom rom onto the phone and being in much greater control of what is on the phone.


  • I think I might try to root another device for some weeks to check how much effort it takes to keep it running. – Melissa Loos Mar 27 '19 at 14:48
  • Once a phone is rooted, there's nothing to keep on top of. Its a great idea to root another device first, if you have a spare one its worth getting familiar with what is expected. It is good to have a look at custom roms and see what you fancy running. Choosing a good rom that is supported will help with keeping the phone in good shape too. – justamarkprime Mar 27 '19 at 15:12
  • Yes, I got a spare one (though not the one I mentioned in another question here^^). I read that many apps from the Play Store don't work on rooted devices and that many app-updates don't work. But that is only what I read, I have not yet rooted any device myself. I do fear a bit that I will damage my phone by rooting, so I can't use it anymore. I am somewhat experienced with computers, but I am not experienced at all with smartphones. Is working with the smartphone device like working with any other pc (where I do not really fear to damage it permanently), or does it take special attention? – Melissa Loos Mar 27 '19 at 15:34
  • Thats interesting, I have not read things like that, if you have any links, would be useful reading. Most newer devices do not need to be rooted for you to flash a custom rom, so that should mitigate those problems. Like with computers, you have to take care with smartphones, there are countless cases of people who have bricked their device, however it sounds like your experiences will put you in good stead. The notes on XDA for rooting a device tend to be well written, so I'd research it and see what your assessment of the process is. – justamarkprime Mar 27 '19 at 15:43
  • thank you very much! Might be the easiest way to get good control over network traffic. The comments I read where in German, and most agreed that rooting was not recommended if you didn't want to put effort in it again and again. I would need to check my history for that, if you understand German. I think I will do some research on how to brick a phone to understand how to not brick a phone ;) – Melissa Loos Mar 27 '19 at 15:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.