0

I'm trying to install lineage 15.1 on my old Sony Xperia V LT25i, which has had a couple of other OS's since the original. When I started the process I could not access the internal memory at all, neither from the phone itself or from my laptop.

I downloaded the OS zip file and the Open Gapps zip I want and started to follow this tutorial. I managed to run the $ fastboot flash boot boot.img command using sudo but now I need to copy the zip files to the phone memory which no longer has a running OS.

I tried using the adb push command but I get an error saying that the device is unauthorized. Running adb devices confirms this:

List of devices attached
CB5A1MMV58  unauthorized

I then tried to find a way to change it from unauthorized to recovery and found a YouTube tutorial which is supposed to solve it, however when I put the phone in recovery mode and run the cd ~/.android && adb push adbkey.pub /data/misc/adb/adb_keys I get this:

adb: error: connect failed: device unauthorized.
This adb server's $ADB_VENDOR_KEYS is not set
Try 'adb kill-server' if that seems wrong.
Otherwise check for a confirmation dialog on your device.

I tried running adb kill-server and then running the above command but I still get the same result. As I do not currently have a running OS on the phone I can not enable ADB directly on the phone.

Any ideas on how I can solve this?

  • You need to use fastboot to flash more of the system first, for example recovery – Chris Stratton Mar 27 at 14:09
  • @ChrisStratton, How do you mean? The boot.img already installed recovery on my phone. – Kajsa Mar 27 at 14:55
  • Boot does not necessarily include recovery, it depends on the device. Clearly you are not in recovery. What you are talking to with adb is an old system image. – Chris Stratton Mar 27 at 15:05
  • It clearly says recovery on the screen, with the options of reboot, apply update, factory reset and advanced. And it is not the old version of recovery that I had with my previous OS. – Kajsa Mar 27 at 15:06
  • That should have been in your question. Sounds like whatever you flashed is broken and you need to start over with good images. Or just use fastboit to install all the partition images as developers normally do. That is literally copying files without an OS - recovery is an OS. – Chris Stratton Mar 27 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.