2

I am a complete noob with Android so please forgive me.

I am tasked with installing Android on a Custom Board from China. Its InsydeH20 BIOS and something called "BayTrail".

Basically, the board is installed inside a Hand Dryer (dont ask). The concept is to install an APP (which is already available), that links to a website, users can play Advertisements through the screen by creating them on the website, the playlist syncs to the app, voila ads play on the Android Board, nifty concept, in reality its a nightmare to get working.

I have tried numerous versions of Android, the App best works on 4.4 but I have it working on 7.1 Nougat.

The main issues I have are:

Teamviewer Host (needs to be installed for future support of the units. This, I have only got working on 1 version of Android (Prime OS)

Screen Orientation - this is my main issue, the screen is 1080x1920 resolution. using a screen rotation app (on Phoenix OS v1.5.0) I can get the screen to display in LANDSCAPE at 1920x108 - great, App works, screen is landscape, Teamviewer DOES NOT work, bummer!

On Prime OS - the rotation app just does not work, it sort of goes in landscape, but in portrait view? The screen is 1080x1920 across the MIDDLE of the screen, with black bars at the top and bottom. Please see this link for screen shot.

But TeamViewer works, and the unit seems more stable on Prime OS, so I think once I have the screen sorted, it will work fine, hopefully?

Things I have already tried.

ADB Build Prop adding these lines, and rebooting - does absolutely nothing!

ro.sf.hwrotation=0

ADB Shell - adding these lines

 1. adb shell root
 2. adb shell remount
 3. adb shell setprop persist.demo.hdmirotation portrait
 4. adb shell setprop persist.demo.hdmirotationlock false
 5. adb shell setprop persist.demo.singledisplay true
 6. adb reboot
 7. adb shell wm size 1920x1080

This is how I have got it to where it is now, but the thing will just not rotate and use LANDSCAPE and FULL SCREEN, like it does on Phoenix OS.

Sorry, if I have repeated myself, hopefully the screen shot will give you a better idea of where I am at, what I need.

And hopefully someone can help?

Currently running Prime OS Standard at this link -

Prime OS Link

0

Try setting the default offset using hwrotation= ...
HW Rotation props are not intelligent, it will not understand that by 0 you mean landscape...

You need to actually set it to a value of rotation out of 360 degrees.

So...

ro.sf.hwrotation=270    

OR

ro.sf.hwrotation=180 

OR

ro.sf.hwrotation=90

OR

ro.sf.hwrotation=0   

If that still is not fixing the issue, then please let me know...

It is most likely being set by default.prop as part of the boot.img - Default.prop properties take priority over Build.prop properties.

  • Is this achieved by adding the line to build.prop? – Nebin Esquire Apr 4 at 11:05
  • Yes... However if it has been set in default.prop, the value in default.prop will be used.... Default.prop is part of the boot.img – Zillinium Apr 4 at 18:36
  • Yeah I've tried all those numbers in build.prop and it does nothing at all. – Nebin Esquire Apr 4 at 21:09
  • Try in default.prop... You need to extract boot.img and edit defult.prop under the ramdisk folder... – Zillinium Apr 4 at 21:45
  • Thanks, I have extracted "ramdisk.img". I get a file called ramdisk, which I can open in notepad. The first 20 lines are readable, and look like default.prep. There is no mention in there for rotation. So I have added the line. – Nebin Esquire Apr 5 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.