0

I've build an app in Unity which has been working fine for months.

I then decided to reinstall the app because of an issue that later turned out to be a problem with a CSV file the app needed to access.

But after I had uninstalled the app and wanted to reinstall it I received the "App not installed Error".

I tried to install a previous version of the app and that installed just fine. I then uninstalled that because I wanted to try the newest version again. But now I'm not just unable to install the newest version but also the version before that. Every time I install and uninstall a different version I'm then unable to install that particular version again.

I've tried: - Rebooting the phone - Deleting the app's folder in the "Android->Data" folder - Just about everything I could find searching on Google for help

I'm on a Samsung Note 8 and I recently upgraded to Android Pie

Edit: I am unable to build a new version because I'm away from home for the next week.

  • I guess that at least borderlines a development question (which is off-topic here) – but how did you try to install? My guess: from within your developmend IDE. Which most likely remembered your having installed it before, and hence tries adb install -r foo.apk. Which would fail with the given error message if the app isn't installed, as -r stands for "reinstall". So why not keeping it installed, and try again? – Izzy Mar 30 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.