5

I recently upgraded my 2016 MacBook Pro to High Sierra 10.4.4 update and since the update "fastboot devices" command hasn't been working. "fastboot" itself gives a response but "fastboot devices" command gives ERROR: Couldn't create a device interface iterator: (e00002bd) ERROR: Couldn't create a device interface iterator: (e00002bd) error. It comes twice on the window.

  • this worked for me!! xda-developers.com/install-adb-windows-macos-linux cant believe it. – Mark Tchourbanov Apr 28 at 5:16
  • "fastboot devices" has been working for me for years until I have upgraded to Mac OS 10.14.4. I think this is a regression of the Mac OS. I'm waiting for a new OS upgrade that fixes this regression. In the meantime, I'm not sure if there is any workaround. – jonathanzh Apr 29 at 19:34
  • I have submitted a bug report to Apple. Following is the link: bugreport.apple.com/web/?problemID=50376579 – jonathanzh May 1 at 18:40
  • I have upgraded to Mac OS 10.14.5 and this regression is still not fixed. It's better to find a workaround. – jonathanzh May 20 at 19:18
  • jonathanzh, have you found a workaround? I'm also on 10.14.5 and haven't had any luck. I have access to a Windows and a Linux PC. – Andy May 22 at 10:05
5

This might be a regression in android-platform-tools. Try fastboot version 9dc0875966c0-android from android-platform-tools 26.0.1 as it works for me on macOS 10.14.4

  • 1
    I confirm that the fastboot version in android-platform-tools 26.0.1 works on macOS 10.14.4. This is a nice workaround before Apple fixes this regression. – jonathanzh May 6 at 23:17
2

I had the same error in version 28.0.3 but it's fixed in 29.0.1. You can downlaod it from the official site.
It's also available from MacPorts

0

This is a Fastboot problem which has been fixed by google. See the release notes here:
SDK Platform Tools release notes

Here is what solved my problem:
Start android studio->go to sdk manager->select SDK Platform Tools -> Check "Show Details" -> Select Android Platform Tools -> Upgrade to 29.0.1 or newer.

See the images for more details:
enter image description here

-1

Have same problem on 10.14.4 2014 13" MBP retina W/ Sony xz2C. Solution was to use bootcamp. If there is a easier solution that would be nice to know.

  • 1
    Thanks for mentioning a solution, Alex! Could you elaborate a little more (like giving a list of steps to perform) for those not familiar with bootcamp? You can edit your post for that. Thanks! – Izzy Apr 26 at 7:00
  • 1
    Searching "bootcamp android" did not a yield a satisfactory result until I found out this is "Boot Camp", a utility for Mac in particular to boot Windows in Mac. As Izzy said, it is best if you could provide detailed steps for this. – Firelord Apr 26 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.