0

I have a Xiaomi Mi A2 Lite and since the update to Android 9, I had troubles to root with TWRP & Magisk. The latest trial was based on the daisy_global_images_V10.0.3.0.PDLMIXM_9.0 images including latest Android Security Patches via OTA. As to TWRP is not working since Android 9 with my phone I tried the feature of Magisk to patch the boot.img. I took the boot.img from the daisy_global_images_V10.0.3.0.PDLMIXM_9.0 images and patched it. Then I run fastboot boot patched_boot.img from bootloader. It took a while until something like system destroyed was displayed.

I had this already with TWRP but after reboot there never was an issue. This time, it was even at a normal boot it wrote: system destroyed. I then re-flashed daisy_global_images_V10.0.3.0.PDLMIXM_9.0. The system booted BUT: my pin is no more recognized for decryption. I tried also to install Android 8.1 but the same problem. What I cannot install is daisy_global_images_V10.0.3.0.PDLMIXM_9.0 with the latest Android Security Patches I had before - I don't know whether that makes a difference.

I'm now lost, without another idea how to safe my data (pictures, etc.) Hope anyone can help me!

Thanks, Stefan

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.