I have a Huawei P20 pro, and cannot receive WhatsApp messages unless I open the App.

A few points to note. There is intrusive data collection by many Apps and also usage of completely unnecessary network data - in my opinion. So I restricted the default Network access. Huawei P20 Pro has (I assume other Huawei models + Andriod in general) a "Data saver" option. This restricts data access. However as a subsetting of this you can make an exception for the Apps you want. Using this path; Settings => Wireless & Networks => Data usage => Data saver (On|Off) => On=> Here choose for "Installed Apps" and "System Apps"

WhatsApp (and few others) selected for exemption, but still no messages unless I open the App. Any ideas?

| improve this question | | | | |
  • Perhaps you need to enable Google Play Services background data too – QuickishFM Apr 11 '19 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.