1

My setup

  • Raspberry Pi running Pi-Hole on static IP 192.168.0.2
  • TP-Link Archer C7 router
    • IP - 192.168.0.1
    • 2.4GHz and 5GHz bands using same SSID
    • DHCP setup
      • Default gateway - 192.168.0.1
      • DHCP range 192.168.0.100 - 192.168.0.199
      • DNS - 192.168.0.2
      • Subnet mask 255.255.255.0
    • Wireless AP isolation is disabled

I got a new Nokia 7.1 running Android 9. It connects to the wifi just fine (receives an IP like 192.168.0.103, DNS settings are set correctly) and can access the internet as well as certain local IPs such as the router admin page and other devices connected to the network, for example a Synology Diskstation.

I noticed I was getting ads on some web pages so tried to access the pi-hole dashboard to check things out. When I tried to access http://192.168.0.200/admin, I receive

This site can't be reached

http://192.168.0.2/admin is unreachable
ERR_ADDRESS_UNREACHABLE

so that explains why I was getting ads but I cannot for the life of me work out why the phone cannot access this one specific local IP address.

My laptop which is on the same wifi network can access the pi-hole dashboard without issue.

This is my first Android 9 device so I might be missing a specific networking setting. Previously I had a Nougat phone that did not show any problems like this.


Update

Noticed the WiFi on the phone was constantly switching between 2.4GHz and 5GHz. Changed the router to use different SSIDs for each band which seemed to work well for a day but it's back to not connecting now.


Another update

Noticed whenever I'm having trouble with LAN connections, there's a TV.b wifi network which appears to be my Chromecast which means it too does not have a connection so this is looking more like an issue with the router.

  • Did you check Private DNS settings introduced in Pie? It's DNS over TLS (DoT) which uses port 853 instead of 53. I suppose 192.168.0.200 is listening on port 53. Did you try to ping (ICMP/TCP/UDP) 192.168.0.200 from Nokia phone or tried to access listening port(s) with nmap? – Irfan Latif Apr 12 at 10:11
  • @IrfanLatif Private DNS is on "Automatic" but DNS shouldn't prevent me from hitting a direct local IP. 192.168.0.200 operates DNS on port 53 but also runs a web dashboard on port 80. Not sure how to ping from the phone – Phil Apr 12 at 15:45
  • You can use ping, traceroute, namp from adb shell or terminal emulator app like Termux. – Irfan Latif Apr 12 at 17:51
  • Make sure the subnet mask you get via DHCP is 255.255.255.0 (not limited to the DHCP IP range). – Robert Apr 21 at 17:57
  • That is the subnet mask, sorry forgot to include that in the question – Phil Apr 22 at 1:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.