I downloaded the latest LineageOS for my latest Device, from Dumplings SF.

firmware, recovery, vendor files.

What I get all the time is that error message "E1001: Failed to update system image" and that he can't mount the vendor partition.

Any ideas ? PS: I can't even flash back to latest Oneplus ROM (or even older roms)....

Update: Meanwhile I use TWRP from "cheeseburgerdumplings" for 8.1 on what lineageOS and the "/vendor" partition is no more tried to be mounted. What I figure out as well, is that if I go with adbs command to know if the filesystem is encrypted or not:

adb shell getprop ro.crypto.state

tells me "encrypted"

Now the big question, which filesystems are encrypted, all ? And which partition or FS does not have to be encrpyted?

Here is the "recovery.log": https://pastebin.com/raw/tKMStdSF


TWRP Error Lineagos Oneplus 5T


I faced the same issue and solved it by setting the settings flag Unmount System before installing a ZIP to false. This is not documented or recommended anywhere, however.

For me, it was LineageOS+MicroG image serrano3gxx. If someone else finds this to solve this error, please leave a note so we can report it accordingly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.