1

I have an issue where Google Play Store will not download updates for a specific subset of my installed apps. I'm using a Sony Xperia Z5 with Android 7.1.1.

When the problem apps attempt to update in the play store the download percentage goes past 100% for a bit at which point it resets to zero and starts downloading again. It tries to download each app three times and gives up. This suggests to me some dodgy cached data somewhere? It also appears like my phone may be having issues downloading the "google play security information update" (although I'm not certain of this) as I will often see a notification that this file is being downloaded, pop up, appear to complete, and go away, and then straight away pop up and download again. This suggests to me that it is doing the same thing as the apps in play store?

I have tried nearly all the recommended actions for fixing play store issues. I have cleared cache and data, and forced stop on Google Play Store, Google Play services and Download Manager and then restarted my phone to no avail.

I haven't removed and re-added my google account (which is another recommendation for play issues) as I'm not sure how much of a pain that will be to re-add? I tried updating to the latest beta version of the play store but that didn't fix the issue and it has been happening for around two months now.

The one thing that has managed to work, temporarily, is to uninstall updates on google play store. This takes me back to a very old version of play store but all downloads then work correctly. The problem I then have is play store insists on periodically automatically updating itself at which point all the same apps stop downloading again! I'm not sure what triggers play store to update itself or how to stop it. Sometimes it happens quite quickly after rolling back sometimes it takes a couple of days.

My only "solution" at this point is to uninstall updates on play store each time it re-updates itself. If I happen to miss that this has happened my phone will sit there happily trying to download the same app updates over and over using tens of gigs of data over a day or two (lucky only on wifi). Each time play store reinstalls itself it also automatically turns "auto update" (which I have disabled) back on!

The fact that it is the same subset of apps that fail each time is weird too. They are a diverse range of apps, some games, some utilities, some educational so this suggests that it's not the apps themselves that is the problem but some kind of corrupted data/cache issue? Some files that play store or the download manager uses that aren't removed when you clear the cache or uninstall play store? I feel like if I could just check a log file somewhere as the play store fails on a download I should be able to work out what is going on but I have I non-rooted phone so I think my diagnostic options are limited?

0

I have found a partial answer to this issue. It appears to be related to a google play error reported as error 963 elsewhere online. I'm not sure how you get the associated error number as I get no message or sign that anything is wrong other than the download being attempted three times and stopping on the third try?

After looking through endless sites suggesting the same old solution of clearing cache and data and uninstalling updates I came across a site that mentions the issue is related to the app being stored on the SD card.

https://www.technipages.com/google-play-error-963

Following these instructions worked for me. Basically, all the apps that were not updating were stored on my SD card. After moving them all back to internal storage I could once again successfully update them.

The only remaining issue I have is if I try and move them back to the SD card (either via the app storage preference or via the auto "you're running out of internal storage move apps to SD card" thing that pops up from time to time) then the next time the app gets an update it fails to complete again and I have to move it back to internal storage to get it to update.

I can only surmise that for some reason when the app is on the SD card google play doesn't have the required permissions to update the data. Having said that it is strange that uninstalling updates on google play also fixes the issue as that suggests that the factory version has the required permissions and this bug has been introduced at a later date.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.