0

I don't want Chrome to be my default browser. I set my default browser to Firefox. Then when I click a link, It opens in Chrome again. I get back to default apps settings to check and I see Chrome is set to default. This is out of my will.

  • 2
    Have you gone to FireFox settings 'Make Default Browser'? Have you gone to Apps/Default Apps/Browser? Are they in agreement? Have you disabled Chrome? – wbogacz Apr 19 at 11:11
  • Yes, 'Make Default Browser' led me to default app settings. Also gone to Default Apps / Browser settings. But after closing the Settings app, things get to Chrome way. Also, for a while, I was able to select Firefox as a default browser and Android would ask me everytime which app to use when I clicked on links. I would say 'Always' on Firefox but would ask again. Today is just Chrome. I did not try disabling Chrome and I think I don't want to do this. – Umut Özdemir Apr 19 at 12:11
  • @UmutÖzdemir I had to disable chrome when even when I had Firefox set as the default browser, all in-app links would open and that browser was marked as "Powered by Chrome". Now with Chrome disabled, things open well in Firefox. I keep Edge browser as a backup. I never had a day when Chrome would override my default browser setting and trust me I've been using Firefox since years. This seems like some device admin app doing it or some app which has the permission to "Modify system settings". You should try again after disabling that permission for chrome or any other doubtful app. – singhnsk Apr 19 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.