After a recent update (Android 9.0), I have noticed that Whatsapp Messenger notifications come up similar to how Facebook Messenger notifications are delivered - with a chat head. This is a circle with the messenger's profile picture showing, and clicking on it opens a small window with the message shown.

I preferred when this chat head was never there, and I got to see a preview of the message for a few seconds just below the top of the screen when a message arrives. Is it possible to turn this feature off? I have tried turning off pop-up notifications, but this seems to be something different entirely, as the chat heads continue to come up.

  • I assume you're using Samsung devices? Because I only found related issues on the net on Samsung devices with Android 9 Pie update with a feature called 'Pop-up Windows' since early 2019. – Andrew T. Apr 21 at 6:05
  • @AndrewT. yes, I am using a note 8. Where can i disable this pop-up window thing for whatsapp? – John Doe Apr 21 at 13:41

Follow this path to enable or disable the mentioned "chat heads". Settings > Advanced features > Smart pop-up view Then toggle whatever applications you'd like to show "chat heads".


WhatsApp does not naively support chat heads. So, this is being done by using a third party app. Probably you installed one, or in a rare case your phone manufacturer baked such a thing into the phone UI. Please look into your device settings and also go through your installed apps if you notice something.

  • Actually, it does. I found this post on another forum where people have the same problem. I haven't installed any such third party app. – John Doe Apr 21 at 3:52
  • @JohnDoe Which device are you using? – Firelord Apr 21 at 4:04
  • 1
    @JohnDoe interesting. Then this is something being done by the OEM. As I said, WhatsApp doesn't support such a thing natively. And as Firelord said and per your comment, it must be the Pop-up windows. – singhnsk Apr 21 at 12:18
  • @Firelord samsung galaxy note 8 – John Doe Apr 21 at 13:42
  • 1
    Aha, I found out what was causing it - Settings > Advanced Features > Smart pop-up view. You're right, it was the device settings :) – John Doe Apr 21 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.