0

I have an "Essential" android phone that is rooted, has terminal and supersu installed, but will not acknowledge that it is plugged into a computer rather than an AC charging station. lsusb on the host computer does not find it.

Under settings, "USB Debugging" is on. This doesn't seem to be helping.

The shell is present and operable with the terminal on the phone itself. curl is present. ssh and sshd are not. I have wireless. How can I get all my files off the phone? Some files are too large to email to myself.

What I feel like I want to do is run tar -cf - . | ssh mydesktopmachine \> android.tar but there's no ssh right now.

1

So I did manage to get it working with SSHDroid. The real problem was not what I thought it was at all.

I unplugged my wireless booster (Buffalo) and it started working. For some reason the booster blocks IP between the machines on the WiFi and the machines on the wired LAN even though they can find each other with ARP. I'm really glad I didn't start leaving a bunch of "does not work" product reviews.

0

Have you tried the following:

  1. Turning USB debugging off and then on?
  2. Changing wires? (sometimes the wire is a bit faulty)
  3. You can install ES file explorer and then use the FTP, it will be transfer over local WiFi, it is pretty fast.
  • Have tried replacing wires and toggling USB. – Joshua Apr 21 at 3:10
  • @Joshua how about the ES file explorer FTP Method? u just need to follow the on screen instructions in ES file explorer to set up ur phone as the server, then from ur computer, u can browse files in ur phone with the windows file explorer – Peter Apr 21 at 3:22
  • I always use the ES file explorer when I forget to bring out my wire – Peter Apr 21 at 3:25
  • I have too many files to pick them up one by one with the UI. – Joshua Apr 21 at 3:46
  • @Joshua then u can just go Network -> View on PC -> then it will give a address to key into ur File Explorer on windows – Peter Apr 21 at 3:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.