0

I bought this Nubia Z17 lite online and I got it with the global version and Google apps preinstalled. Everything worked but I wanted the new Nubia UI 6.0 and so I installed it from the Chinese website. Now, that doesn't support Google by itself, so I used twrp and fastboot and I rooted the phone with superSU and installed open GApps. My problem is that I can't see any permission in my phone settings, and with this I mean that if I go to settings>apps>permissions and I scroll down to ALL the Google apps I installed, none of them have any permission. I installed App Ops to change the permissions, and they in fact have permissions, but still they don't always work. For example, if I go to Google play games, it will give me the error "Google play games had trouble with Google play services, try again". Until 10 minutes ago, if I went to Whatsapp, it told me I had to activate sms permissions on Google play services. Now that I gave it permissions through App Ops, it just doesn't work. Whatsapp asks for my number, I click ok, then nothing happens. No permission asking, no message, nothing. I have my sim and I can also use mobile data, btw. And if I open YouTube, nothing works. I can't use the search bar, I can't add accounts because it's an infinite loading, I can't use any of the bottom buttons (like trending or subscriptions). What doesn't make sense to me is that apps like Google play store and chrome work perfectly, while others are just broken. Maybe I used a wrong version of GApps? I initially followed a tutorial but the GApps link there was broken so I couldn't use that and I went for GApps Android 7.1 on their website. I noticed that on the website it says that for GApps over Android 7 rom will need a patch. Could that be it? I really don't know what that means, I clicked on the link and tried to understand but I couldn't, so I'm asking help. Why are me GApps acting like that?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.