1

I've recently been trying to flash twrp on my Lg Aristo 2, when I ran the code to OEM Unlock a device it came out with the same "FAILED (remote: 'unknown command')". I started my phone back up and it came to a set up screen, I set up my phone and it said it was OEM Unlocked. When I try to flash a custom recovery, or run any command with fastboot at the beginning i get "FAILED (remote: 'unknown command')" and it doesn't work. Can someone please help?

  • adb devices and fastboot devices does show the phone serialno? – alecxs Apr 28 at 11:39
0

Seems fastboot is broken or disabled since Oreo.
First you have to downgrade ROM to Nougat. You can flash *.KDZ files with LGUP or LG Flash Tool.

LGUP

Then it should work as usual:

  • Make sure you have enabled
    System Settings > About Phone > Developer Options > Enable OEM unlock, and
    System Settings > About Phone > Developer Options > Enable USB debugging
  • check adb is working

    adb devices
    
  • check fastboot is working

    adb reboot bootloader
    fastboot devices
    

WARNING: Factory reset, all data lost!

  • unlock the bootloader (one of these should work)

    fastboot oem unlock
    fastboot flashing unlock
    
  • if unlocking was successful, you can test recovery without flashing

    fastboot boot <path>/recovery.img
    
  • then reboot into bootloader and flash recovery

    adb reboot bootloader
    fastboot flash recovery <path>/recovery.img
    
  • if you fail on one of these steps, make sure you have installed latest drivers and platform tools dl.google.com/android/repository/… – alecxs Apr 28 at 12:03
  • fastboot flashing unlock comes out to: (bootloader) Device already : unlocked! OKAY [ 0.003s] Finished. Total time: 0.008s fastboot boot recovery.img comes out to: Sending 'boot.img' (16954 KB) OKAY [ 0.555s] Booting FAILED (remote: 'unknown command') fastboot: error: Command failed – Zavier Apr 28 at 18:17
  • check path is quoted correctly for example fastboot flash recovery "C:\Users\My Name\Downloads\twrp-recovery.img" edit: ok then your recovery.img might be corrupt, try a different one – alecxs Apr 28 at 18:29
  • Did that got same error, also downloaded the recovery.img again – Zavier Apr 28 at 18:38
  • Downgrade your firmware to the LMX210MA forum.xda-developers.com/showthread.php?t=3805141 – alecxs Apr 28 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.