0

I am trying to look at the processes tagged to each individual tcp connection using busybox netstat -p as shown from their docs. However, after rooting and checking my root with RootChecker, it seems like i have root access and SU access; but unable to run adb shell busybox netstat and it shows the error

Running busybox netstat command

From android's terminal shell

I am using NoxPlayer 6.2.6.1, running android version 4.4.2. This shows a picture of my attempt to do the same thing in Terminal Emulator itself.

RootChecker

And this shows an image of rootChecker verifying that i rooted the phone properly.

I came across articles saying that /proc/net is a symbolic link; thus only providing a "shortcut" to the file path and not the actual file, thus, netstat command was unable to be executed?

Hope to get some help for this issue.

  • NoxPlayer has a settings to enable root access. Check its settings – Reddy Lutonadio Apr 29 at 3:13
  • yeah i have done so, it still doesnt work! thanks though – Jun Yang Apr 29 at 4:44
  • What method did you use to root the device? It seems you have rooted using some exploit and it's an incomplete root; some capabilities are missing. Just to make sure, you don't have SELinux enabled on your device? Also, did you try with some other netstat or ss binary? Most ROMs do have one or both of these binaries in /system/bin or you can get a static one. – Irfan Latif Apr 30 at 8:30
  • I rooted using adb root, and NoxPlayer's root setting. I have ensured that SELinux is not enabled on the device, i used getenforce and it returned disabled. I tried the native netstat binary from the ROM itself and it worked. It is only busybox netstat that does not work. I tried using lsattr on /proc/net folder itself and it has a incomplete ioctl error. However, i managed to fix the problem by upgrading to Android 7.2. However, i still have not understood the root problem. Busybox's requirements are linux kernel 2.4.x and above iirc, and my linux kernel in the android emulator is 3.40 – Jun Yang Apr 30 at 9:30
  • Should be a kernel compatibility issue such that the Nox's kernel for Android 4.4.2 has some missing capabilities as busybox is known to support Android (4) kitkat. However, i do still need to understand the ioctl error. Another thing i found out is that the Android 4.4.2 kernel does not contain strace or ltrace for me to trace the syscalls to understand where the problem lies. – Jun Yang Apr 30 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.