0

I've been trying to flash stock ROM on my Samsung J7 Max. Briefly, these are the steps I followed :

  1. Enable Developer Options
  2. Disable OEM lock
  3. Reboot phone and open into Download Mode (Power+Home+Down)
  4. Open Odin 3.12 on PC (with latest samsung drivers installed)
  5. Connect phone via original data cable
  6. Load the four *.tar.md5 files into respective slots (BL,AP,CP,CSC taken from here)

    Until now the message at top in Download Mode is:

        ODIN MODE (HIGH SPEED)
        PRODUCT NAME: SM-G615F
        CURRENT BINARY: Custom
        SYSTEM STATUS: OFFICIAL
        FRP LOCK: OFF
        OEM LOCK: OFF
        WARRANTY VOID: 0x1 (0x30d)
        MTK SECURE BOOT: ENABLE
        AP SWREV: B2 K0 S0
        SECURE DOWNLOAD: ENABLE
    
  7. Disable Auto-reboot and Click Start. The process runs for about two minutes and then following two errors occur-

    On the phone: this line is printed-

        SW REV CHECK FAIL : [lk]Fused 2 > Binary 1
    

    On Odin: Here's the complete log:

    <ID:0/004> Removed!!
    <ID:0/004> Added!!
    <ID:0/004> Odin engine v(ID:3.1205)..
    <ID:0/004> File analysis..
    <ID:0/004> SetupConnection..
    <ID:0/004> Initialzation..
    <ID:0/004> Get PIT for mapping..
    <ID:0/004> Firmware update start..
    <ID:0/004> SingleDownload.
    <ID:0/004> preloader.img
    <ID:0/004> lk.bin
    <ID:0/004> trustzone.bin
    <ID:0/004> param.bin
    <ID:0/004> efuse.img
    <ID:0/004> RQT_CLOSE !!
    <ID:0/004> 
    <ID:0/004> Complete(Write) operation failed.
    <OSM> All threads completed. (succeed 0 / failed 1)
    

Note that this same error happens if I try to upload a random tar file. So it seems an invalid BL file is causing the issue, but I've re-downloaded and verified the md5 hash of the BL file.

Also, I cannot open the recovery mode. Even when FRP Lock is off, the phone is showing a screen similar like this:

Recovery mode not accessible

The message at the top on this screen says Rollback version is not matched (md1rom). Can anyone explain what this error is?

Before flashing, my phone had Android 8.1 and the firmware was also last updated on 21 Mar 2019 (Android version: 8.1, code: G615FXXU2BSC1).

Edit : I've also tried to upload individual tar.md5 files to device and found that files other than BL file upload successfully and the above error is generated when I try just the BL file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.