1

I've got a brand new Motorola Moto G7 Power running Android 9.

I also have Ubuntu 19.04 running on my desktop.

I want to root the phone.

I've managed to unlock the bootloader using Motorola's online instructions and the adb and fastboot utilities that come with Linux.

The next step is to flash a custom recovery application on the recovery partition.

I'm trying to flash twrp-3.3.0-0-river.img, a new image that I grabbed from here.

When I tried to use fastboot to flash the image, I got this error: enter image description here

After this failed attempt, I attempted to put my phone into recovery just to see what would happen.

What I got was a screen displaying the Android mascot on its back with its chest plate opened and a black exclamation point inside a red triangle.

The words "No Command" were displayed underneath the graphic.

After waiting a few minutes, the phone, on its own, booted normally.

My phone's OS seems to operate perfectly fine.

I can only surmise that whatever was originally on my recovery partition from the manufacturer has been wiped and there is now nothing on the recovery partition at all.

So, I decided to see if I could boot into the TWRP image directly without flashing it.

So, I ran this in the terminal window: fastboot boot twrp-3.3.0-0-river.img

I received this as a response: enter image description here

There didn't seem to be any errors.

The phone, however, switched from the bootloader screen to the Motorola splash screen, and then just shut off with no further response.

So, what am I missing?

How can I flash this image onto the recovery partition of my phone?

  • fastboot is disabled for flashing. downgrade to nougat – alecxs May 1 at 21:03
  • Thanks for the reply. Though, can you elaborate, please? I'm new to all of this. I assume Nougat is an older version of Android? How do I downgrade to another version of Android if I can't flash things? I mean, I would need to flash a new ROM onto my phone to do as you suggest. But, my very problem is that I CAN'T flash things. – tensor May 1 at 21:09
  • You can flash with a flash tool (maybe QPST?) but unfortunately there is no stock nougat rom available for your device, sorry for misleading. Maybe you can find pre-rooted rom, or rooting app. with root you can use dd for writing twrp to recovery partition (if it has one) – alecxs May 1 at 23:04
  • Your device don't have recovery partition, it is inside ramdisk. thats why fastboot flash recovery fails - see first screenshot "Invalid partition name" – alecxs May 2 at 10:34
  • OK, thanks. But, why are manufacturers doing things this way? Why bundle recovery inside of the boot image and not just have it be its own partition in memory? – tensor May 2 at 16:55
1

G7 Power, being a new device, has the new A/B partition layout, requiring new installation procedures that differ from standard A-only devices. This is clearly outlined in the thread where you got your image from:

This device has 2 "slots" for ROMs / firmware. TWRP will detect whichever slot is currently active and use that slot for backup AND restore. There are buttons on the reboot page and under backup -> options to change slots. Changing the active slot will cause TWRP to switch which slot that TWRP is backing up or restoring. You can make a backup of slot A, switch to B, then restore the backup which will restore the backup of A to slot B. Changing the slot in TWRP also tells the bootloader to boot that slot.

Decryption only works when TWRP is permanently installed.

Installation

To temporarily boot this recovery:

fastboot boot twrp-version-build-river.img

To permanently install it:

  • Temporarily boot TWRP
  • Put the TWRP image in your external SD Card or, in case you don't have one, push it to /data with adb this way: adb push twrp-version-build-river.img /data/
  • Tap Advanced -> Install Recovery Ramdisk -> Navigate to /data or /external_sd and select TWRP -> Swipe to Install
  • If you previously installed Magisk: Select Fix Recovery Bootloop from Advanced to fix/avoid recovery bootloops
  • Done! Optionally you can delete TWRP from /data or from your external SD Card now.

Read more carefully next time...

  • Thanks. But, that's my problem. Read where I wrote this in my original post: So, I decided to see if I could boot into the TWRP image directly without flashing it. So, I ran this in the terminal window: fastboot boot twrp-3.3.0-0-river.img I received this as a response: There didn't seem to be any errors. The phone, however, switched from the bootloader screen to the Motorola splash screen, and then just shut off with no further response. I can't run the image. My phone doesn't display anything. It just shuts off. – tensor May 2 at 1:39
  • Any ideas of how to get around this problem? – tensor May 2 at 1:40
  • So I only answered the less relevant half of the question (i.e. how to install permanently)... I don't see why it would do that (probably related to you using Ubuntu and the fastboot that comes with it, not sure), but I think you should redirect the question to that thread instead. – Andy Yan May 2 at 2:07
  • should i use windows instead? I couldnt find the drivers for windows. when i put my phone into bootloader mode, windows 7 cant find the drivers for it – tensor May 2 at 2:13
  • the xda thread is for G7 not for G7 Power, guess it's wrong twrp image. besides this it's a known fact that fastboot flashing is not working any longer since Oreo for some devices (only oem unlock works). You can try mfastboot.exe (fastboot for motorola) but it is outdated – alecxs May 2 at 11:35
1

The twrp.img you trying to boot from is for Moto G7 (river). It is the wrong recovery, thats why it fails.

Unfortunately there is no TWRP available for your device Moto G7 Power (ocean). But you have options.

You can root your phone with Magisk.
https://forum.xda-developers.com/showthread.php?t=3923857

You can port TWRP for your device.
unpack your boot.img
find recovery inside ramdisk
unpack recovery
unpack twrp recovery
replace kernel, fstab and *init.rc
repack ported recovery
try if it is fine from fastboot boot recovery.img
replace recovery inside ramdisk
repack boot.img
try if it is fine from fastboot boot boot.img
flash boot.img from fastboot (A/B)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.