1

P9 Lite, everything was fine until this evening when I updated from Magisk 18 to 19.1

Got Decryption unsuccessful error, flashed magisk uninstaller, wiped data + cache + dalvik and tried data format from TWRP. Nothing worked.

I'm going on a trip tomorrow so I need to be able to use the phone asap.

1

I had the exact same issue when I did an internal upgrade from 18 to 19.1 last night on my Huawei Mediapad M3. I wiped the data as was recommended but it keep rebooting into the unable to decrypt storage.

The easy fix is to boot into fastboot and flash your original, non-magisk boot image. I wish I had tried that before actually going through with the data wipe, as I'm fairly sure that was unnecessary.

If you still have your lower version magisk modified boot image, that will work too, although mine was so old I had to use an older version of magisk manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.