0

This is a somewhat silly situation, we have this third party application that stopped working on our work devices, its pretty obvious that some request is failing under the hood, so I set up a HTTPS sniffer on my desktop as a proxy.

But then, everything works flawlessly once I set the proxy on my device... Now I don't know how to properly debug this.

I'm using CharlesProxy for Windows, I've tried mitmproxy but the problematic application wasn't accepting the mitm certificate.

What can I try here? Is there any way I can sniff the HTTPS traffic from inside the phone? Like an app? Its a very weird error that seems to be solved be having a certificate and a proxy(?), but I need to sniff the request somehow because the application is not giving me any messages.

I can't use an emulator as this is a device specific issue. The error does not comes up in emulation.

The device I'm using is a Galaxy Tab A Android 5.11

  • At the very least, I think this is related for sniffing HTTPS traffic directly from the phone: Listen which URLs an app tries to connect. I have an answer in that question which worked well around 2 years ago but currently not working on my device. But I think there's nothing wrong in trying it yourself... – Andrew T. May 2 at 17:12
  • I am not sure if it still works but I used to use a root app called Network log to check which app was using my internet; I don't remember if it can do full fledged packet sniffing. – SSS May 2 at 18:19
  • If intercepting the network traffic is not a solution you can try to use a rooted device and use Frida to hook and monitor network methods: stackoverflow.com/questions/46711786 – Robert May 3 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.