1

My Redmi 5 plus won't boot as I messed up everything while trying to flash a couple of ROMs. At first the two ROMs that I flashed were working well. But after some time, whatever ROM I flashed, the phone started to restart while setting up the first boot (choosing language, region, etc.) and no further. So I tried wiping every partition there is under the TWRP wipe section (cache, system, vendor, data, internal storage, and so forth). Then flashed a custom ROM again with and without GApps but no success. I noticed that the phone even started to restart before the first boot finished. Also, after flashing stock ROM, TWRP said no OS installed. I even tried flashing stock MIUI ROM in fastboot mode. Although it went well, still bootloop and the device keeps restarting. However, before all of these problems, I did take a backup of every partition, leaving nothing behind, so I restored everything but again the "No OS installed, are you sure to boot?" message. Now I'm freaking out, not knowing what to do. I read somewhere that flashing via QPST tool may help but I'm having problems with installing it.

If I manage to make my phone work again, I will not flash any other ROM, ever.

  • Just a correction of terms: if you had really "bricked" your phone, it wouldn't boot at all (as a brick doesn't boot anything), see What does it mean to “brick” your phone? Apart from that: the "and so forth" details might give a clue. What else did you wipe? Cache and data is no issue. System isn't if you flash a fresh ROM afterwards. Not sure about vendor – but what else? Like, modem? Obviously not boot or recovery from what you describe. – Izzy May 5 at 13:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.