I have a Samsung Galaxy Note 8 running Android 9 and One UI. Google Photos will not back up anything.

All I am getting as a Getting ready to back up and 185 items left perpetual spinner at the top of the app. When I attempt to manually back up a single photo or a group of photos, I receive the message Will upload when connected to Wi-Fi.

I have unlimited data and am perfectly happy with it backing up over my cellular data connection. However, going into Settings->Back up & sync->Cellular Data Back Up, I see that both Photos and Videos are enabled. So it should be backing up over cellular data. But it's not.

What am I missing?

  • App up-to-date? Have you tried force closing and trying again? Have you tried rebooting the phone and trying again?
    – user202027
    Commented May 7, 2019 at 18:09
  • Thanks for replying. I have just tried a force-stop on the app with no success. Following that, I have also just rebooted the phone and the issue persists. This has actually been a problem that I've been dealing with for probably as long as I've owned the device (which is over 1.5 years now) but has not been a high priority until recently.
    – Sturm
    Commented May 7, 2019 at 18:48

1 Answer 1


I was able to finally get Google Photos to back everything up. It's not a perfect solution, but it does seem to work for now.

Uninstall / Reinstall.

I just completely uninstalled the app, then immediately reinstalled it from the Google Play store. One of the first things it asked about in its "first-time setup" procedure was whether or not I wanted it to backup my files over cellular data. It defaults to "Wi-Fi only", but I changed it so it would back up on both Wi-Fi and cellular data.

After going through the rest of the "first-time setup" prompts, it began backing everything up, as well as giving me a "clean up ### MB of files" option. I chose that because, why not? I noticed that it did go ahead and back up all of my photos, but the spinner kept running at the top of the app, saying 285 items left (I'm not sure of the exact number) and appeared to be stuck at that.

I decided to let it go and see if it would eventually get through them all anyway. Hours later, I saw that it was on 162 items left. Finally, hours after that, I got the much-sought-after cloud-with-a-checkmark icon. It had finished backing them all up.

Perhaps it got stuck on some long video files or burst-shot photos—I don't know. In any case, I think the uninstall / reinstall procedure is what did the trick for me.

  • 2
    Always appreciate a user who finds an answer and explains it, instead of leaving us all hanging
    – unixandria
    Commented May 8, 2019 at 22:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .