3

I have an Acer Liquid Metal, Gingerbread...

I've tried installing Python on Android (and s4la: http://code.google.com/p/android-scripting/) but when I run the hello world script I get:

dlopen libpython2.6.so

Traceback (most recent call last):

File "compass.py", line 2, in <module>

droid = android.Android()

File "/sdcard/com.googlecode.pythonforandroid/extras/python/android.py", line 34, in __init__

self.conn = socket.create_connection(addr)

File "/home/manuel/AptanaStudio3Workspace/python-for-android/python-build/output/usr/lib/python2.6/socket.py", line 498, in create_connection socket.gaierror: [Errno 8] hostname nor servname provided, or not known."

Any ideas?

3

Easy peasy:

I was using adaway (an app that blocks ads) and somehow its tweaking of my hosts file was not accepted by Python.

Yay! :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.