1

I'm trying to access the following page using Chrome on my Galaxy S10+, but the website always returns the desktop page, even with the Desktop site check box unchecked.

Facebook's built-in browser seems to have no issue displaying the correct page.

1

I recently had a problem with gmail.com trying to get the desktop site to display (setting rules anđ labels requires the desktop site). Somehow, the act of typing gmail.com into the browser does not show the desktop site but following the link from google.com works. I know this is backwards from your problem, but the presence or absence of extra data in the link or cookie can cause this behavior on certain sites. You can try deleting cookies for this site and try différent links from other sources.

I'm a web developer too and there are libraries like bootstrap that can switch to a mobile format that depends solely on the width of the page. It completely ignores the desktop checkbox and uses CSS and js to reformat the page even on a desktop computer if the window is resized. In this case, there really is no 'mobile site'. Viewing with your phone in portrait mode should work but landscape may or may not.

Facebook's browser may be a different size window, or may not be standardized to detect screen size with bootstrap, You could also have a chrome plugin that is causing an issue. If I had to guess, I'd say that you need to delete the cookies (which will delete some login info) and try again. Just keep in minđ that not every site responds to the checkbox in chrome. That only works if there are separate pages for mobile and desktop which is not the way that bootstrap works.

BTW, I just saw your link and tried it. I can use the checkbox on chrome on my s10e and I can switch from mobile to `desktop without issue.

1
  • It's a while since I encountered this issue, and truth be told, I'd forgotten about it until now. A quick check of the link has it working for me again, and I cannot reproduce the old issue. Perhaps it was to do with page width; perhaps it was to do with cookies; I don't know. Either way, I think this answer is probably the best one could expect, so I'll accept it.
    – LongTP5
    Aug 12 '19 at 2:08
0

enter image description here probably you have turn on some dev feature on chrome. It is working fine on chrome...

1
  • That's my guess too, but I'm not sure where to begin.
    – LongTP5
    May 12 '19 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.