1

I've tried to upgrade the rom in MOTO G4 Plus using TWRP version of 3.2.1.0 and during installation process I wiped out the existing android 7.0.1 without backup(understood the cost of backups now). As I faced error while installing android 9.0.1 with error 255 code because of TWRP some upgrade issue couldn't complete the installation process successfully.

I tried multiple ways to upgrade TWRP which was not successful and even fastboot commands aren't working now. Whenever I try fastboot + combinational command like devices and etc it goes into an infinite loop with an error code iterator not found. After a good amount of search found about ADB and happily can connect to my device using ADB now. Then started trying with multiple options like adb side load after reading multiple forum answers and posts I did pushed a rom to scared/data/media after reading this forum NEED HELP: Accidentally deleted OS in TWRP/Cant install Rom which was successfully pushed but didn't do any thing nor I couldn't understand what to do after pushing it.

Then started search again to install stock rom in any different ways before coming here and stumbled at this question which is similar did read the question and included forum post in it to go start the process when I did download stock rom stock rom download couldn't find any flashall.sh file to start the process

Now I'm stuck and couldn't find better place to find a working solution for this situation. Can somebody help me? What can I do while my phone is in this state?

  • 1
    QPST Flash Tool – alecxs May 16 at 12:37
  • That ROM seems to be for G4 Plus. I don't recommended playing with it when your device is already bricked. – Firelord May 16 at 15:03
-1

Here is the Full Forum discussion link to the problem I've faced. Thanks everyone who tried to help me out.

For Quick Solution follow this steps mentioned below:

  1. If you still have access to TWRP on your device? please push 32bit flashable ROM to your device.
  2. Try with a TWRP flashable like the stock ROM Oreo flashable https://forum.xda-developers.com/mot...-test-t3873367 and follow the instructions to install it (i.e. push to your device, or copy to an SD card, then tap install in TWRP to flash it to your device). This TWRP flashable should work on this mentioned TWRP version since it's 32 bit.
  3. The stock ROM download would still require fastboot, so I'm not sure why the fastboot is not working and not choosing the fastboot method as of now.

FYI: error 255 when flashing custom Oreo or Pie ROMs means that the TWRP is 32 bit, whereas the custom ROM requires a 64 bit TWRP.

  • 2
    It is best if you mention the details behind that link because this answer would lose its usefulness should the link expires. – Firelord May 17 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.