I've been using my app as a device owner app since Android Lollipop. I have a new device here which I want to be a device owner too. It is a Samsung Galaxy Tab A 10.5(2018) SM-T590. I am currently running this version of the ROM: T590XXU2ASC1.

I am not using the NFC method. I usually create the /data/system/device_owner.xml file by myself. But since it is not working, I tried this method:

  1. Factory reset the tablet in recovery mode

  2. Pass through the annoying startup menus

  3. Set lock screen to none

  4. Enable USB Debugging

  5. Install my app adb install MyApplicaton.apk

  6. adb shell dpm set-device-owner com.example.myapplication/.MyApplicationReceiver. It always says success when I execute the command.

  7. Start my app, I can pin/unpin my app without problem.

  8. Reboot, and then the famous message appears every time:

    Workspace has been locked
    Unauthorized software has been installed on your device. Workspace has been locked to prevent any unauthorized access. Contact your admin.

Then if I press on the FACTORY DATA RESET button, the workspace app crashes then pops back.

I tried the kioskModeDemo app and the androidDeviceOwner sample app and they all do the same problem.

Does anybody have any hints of why this is not working anymore on Android 8 Oreo?


1 Answer 1


I found the problem: once you OEM unlock (custom OS) your device on a certain Samsung Knox level API, you can't be the device owner anymore on this device.

This is from Samsung Knox page:

"Cannot create work profile" "The security policy prevents the creation of a managed device because a custom OS is or has been installed on this device".

The device could be vulnerable to potential attacks with custom OS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .