0

just to provide some background, 1 year ago I bought a Nokia 6 TA-1021 Model, as soon as I got it, it said that it wanted to upgrade the system from Nougat to Oreo so I allowed it, then it happened I tried to install an App that is 1 GB of size and it did not allow me it said that there is an error 404 or sometimes 900 and something, then I tried installing an app that is 500 MB and it also did not work with the same error, I tried installing an APP below 500 MB and it worked, so I was like maybe its an error in the upgrade or something, I searched for solutions but non worked for me and I still have after 1 year the same problem, I have to use hacky solutions to download apps but I don't like it, I have cleared the playstore cache and few more things related to playstore it did not work, I restarted the phone it did not work, I signed out of google account then signed back in and it did not work, I created a new google account to see if it would be fixed it also did not fix it, now few days I upgraded the phone to Pie in hopes of this problem might be fixed but it also did not work now the APP that is 1Gb downloads till the last MB of the 1GB and it resets the download and takes me back.

I am really out of solutions what is the problem and how to fix it?

Phone name: Nokia 6

Phone Model: TA-1021

Operating system:

Android version: 9

Android security patch level:1 April 2019

Build number: 00WW_6_17D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.