When I press "Start" in Odin3 3.13, the log just says:

<ID:0/006> Added!
<ID:0/006> Odin engine v(ID:3.1.1301)
<ID:0/006> File analysis..

Then it is stuck forever, with the desktop computer's CPU constantly at 30% and 0% disk usage.

The same happens regardless of whether I start Odin then connect my device in "Downloading" mode, or whether I connect my device first and then start Odin.

Question: How to solved the problem, and successfully download the patched firmware?

My configuration is: - AP: magisk_patched.tar produced by Magisk from the Samsung Galaxy S10e firmware AP_G970FXXU1ASD5_CL15820661_QB23234096_REV01_user_low_ship_meta_OS9.tar.md5 - Options: Disabled Auto Reboot, so that only F. Reset Time is left enabled.

enter image description here


2 Answers 2


I did 3 things, tried again, and it worked (I mean it got past File analysis). I am not sure which one of the 3 things did the trick, unfortunately. You might want to try them all.

  • Run SAMSUNG_USB_Driver_for_Mobile_Phones.exe
  • Use a different USB port, for me COM7 instead of COM6.
  • Get the ROM for my phone's region. It is binary equal to the file I tried yesterday, though, so I doubt it changed much.

i found that you must use the correct version of odin. For example, if your md5 file made in year 2015, you need to use the same odin version of the year 2015 (odin v3.07)

Try this by myself and it works. May work for your phone too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .