I have a Nvidia Shield Tablet that froze on me. After powering down it hangs on the nvidia boot up screen when I try to boot it up. Nvidia support says it is a 'soft-brick', as I can't get into recovery mode from fastboot. I am trying to get a recovery image on the tablet. However, the bootloader is locked and I'm pretty sure USB debugging was not enabled ahead of time. Therefore, I can't perform an unlock using adb, and so can't flash a recovery image. When trying to access through a platform-tools terminal, it doesn't show in a list of adb devices.

I'm pretty confident I have the correct drivers installed on my windows PC, which is connected to the tablet via USB.

Nvidia Shield Tablet Wifi (2014 version)

Any help is appreciated at this point, I can't think of anything else to try. Sorry in advance for mixing up terms etc. I've just been researching the past few nights and trying to find a solution. I'm far from an expert.

I've tried these links, here and here but they seem to require USB debugging enabled or ability to access recovery mode from fastboot.


  • Nvidia support is wrong. it is not a 'soft-brick' it is a hardware failure
    – alecxs
    Commented May 26, 2019 at 12:21
  • you have serialno, try to claim the battery maybe you will get a replacement nvidia.com/en-us/shield/support/tabletrecall
    – alecxs
    Commented May 26, 2019 at 13:09
  • when your serialno is between 0410215901781 to 0425214604018 you will get a new tablet for free
    – alecxs
    Commented May 26, 2019 at 14:29

1 Answer 1


adb and fastboot are different modes. you can enter recovery without usb debugging. Press and hold Power + Vol Down. This is the bootloader screen. Now navigate to recovery with Vol Keys, Power to confirm. Wait a Moment. When the android symbol appears, press Vol Up + Power to enter recovery. Now do Factory reset.

If device is locked you may not be able to enter recovery. you can unlock it from fastboot and try again. Unlocking will factory reset your tablet. Download platform_tools from google. Enter fastboot mode from bootloader screen. Connect the usb cable. Install the drivers. Open the cmd.exe as administrator. navigate to the folder. check with fastboot if the serialno appears. unlock.

fastboot devices
fastboot oem unlock

then boot TWRP and see if partitions can be mounted. at least /system and /cache should be mountable, otherwise something is wrong. /data is encrypted but should be mountable too. for more info see here. Do not flash TWRP to recovery partition, first backup stock recovery!

fastboot boot twrp-3.3.1-0-shieldtablet.img

in twrp, there is a option reboot recovery which should you bring to recovery mode. if not, you still have to option to backup/wipe partitions from twrp. start with wiping cache. if phone is still not booting, reboot into twrp and format data. if any error occurs, you can pull the log from adb at any time. post the log file in the twrp support thread and ask for help. try another twrp version (3.1.1-0) depending on your android version

adb pull /tmp/recovery.log C:\Users\Admin\Downloads\platform_tools\recovery.log

if you need to enable usb-debugging from recovery, you may modify /system.
(but also the other methods you linked above should work)

pull the /system/build.prop and edit the following lines with Notepad++ (make a copy for backup)


mount /system writeable, then push it back to phone. if you don't want to modify /system you can try to push it /data/local.prop (but i guess it is not supported on this rom) or do create a file /data/property/persist.sys.usb.config (i don't have exactly read this posts above)

adb push "C:\Users\Admin\Downloads\platform_tools\build.prop" /system/build.prop

Now place the RSA-Key somewhere on the phone and merge it into adb_keys

adb push "C:\Users\Admin\.android\adbkey.pub" /tmp/adbkey.pub
adb shell
mkdir -p /data/misc/adb
cat /tmp/adbkey.pub >> /data/misc/adb/adb_keys

if root access is required, you can change ro.secure=0 in build.prop too (but not recommended)

  • Thanks very much for your reply. I initially tried navigating to recovery the method you outlined, however the Vol Up + Power has no effect when I'm on the android symbol screen - it just says "No command". I can see the serial number when I run the command terminal and use 'fastboot devices'. 'fastboot oem unlock' actually appears to be doing something. I see... erasing userdata...erasing user data done...erasing cache...erasing cache done. unlocking... but then it just hangs. I've left it go for 10-15 minutes. If I cycle power it's still locked. Appreciate any further input :)
    – EvanH
    Commented May 25, 2019 at 23:35
  • maybe this triggers FRP Lock but this can be solved from twrp
    – alecxs
    Commented May 26, 2019 at 1:03
  • Trying to boot TWRP returns an error: "FAILED (remote: 'Bootloader is locked.'). I admit you lost me a bit with the /system modifying. Not sure what you mean by 'pull'. Is this performed with an adb pull (like you have suggested to do with the log file?). I still can't get the device to be recognized using adb, so I'm not sure this will work. I'll have to read more about it tomorrow. I don't expect you to be too hand-holdy, but I appreciate your help.
    – EvanH
    Commented May 26, 2019 at 3:45
  • You don't need usb-debugging, it is just to fulfil the question headline
    – alecxs
    Commented May 26, 2019 at 7:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .