0

I have an Acer Chromebook 13 with Termux installed. I've run termux-setup-storage and I have nodejs installed (no errors). I'm trying to make a small node app under the downloads directory -- as termux references it: /data/data/com.termux/files/home/storage/downloads/_dev/base_app/api

I have created a package.json file there, and when in that directory, I ran npm i -s express

this seemed to run ok, but it didn't update the dependencies in the package.json file.

npm install express --save produced a long list of warnings (the same one over and over - tar EPERM: operation not permitted, futime) and then an. I failed to copy the error at that point.

then I tried running npm install mongoose --save had similar behavior. The error I got then was

npm ERR! path ../semver/bin/semver
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall symlink
npm ERR! Error: EACCES: permission denied, symlink '../semver/bin/semver' -> '/storage/emulated/0/Download/_dev/base_app/api/node_modules/.bin/semver'
npm ERR!  [OperationalError: EACCES: permission denied, symlink '../semver/bin/semver' -> '/storage/emulated/0/Download/_dev/base_app/api/node_modules/.bin/semver'] {
npm ERR!   cause: [Error: EACCES: permission denied, symlink '../semver/bin/semver' -> '/storage/emulated/0/Download/_dev/base_app/api/node_modules/.bin/semver'] {
npm ERR!     errno: -13,
npm ERR!     code: 'EACCES',
npm ERR!     syscall: 'symlink',
npm ERR!     path: '../semver/bin/semver',
npm ERR!     dest: '/storage/emulated/0/Download/_dev/base_app/api/node_modules/.bin/semver'
npm ERR!   },
npm ERR!   stack: "Error: EACCES: permission denied, symlink '../semver/bin/semver' -> " +
npm ERR!     "'/storage/emulated/0/Download/_dev/base_app/api/node_modules/.bin/semver'",
npm ERR!   errno: -13,
npm ERR!   code: 'EACCES',
npm ERR!   syscall: 'symlink',
npm ERR!   path: '../semver/bin/semver',
npm ERR!   dest: '/storage/emulated/0/Download/_dev/base_app/api/node_modules/.bin/semver',
npm ERR!   parent: 'api'
npm ERR! }
npm ERR!
npm ERR! The operation was rejected by your operating system.
npm ERR! It is likely you do not have the permissions to access this file as the current user
npm ERR!
npm ERR! If you believe this might be a permissions issue, please double-check the
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator (though this is not recommended).

npm ERR! A complete log of this run can be found in:
npm ERR!     /data/data/com.termux/files/home/.npm/_logs/2019-05-27T01_18_24_536Z-debug.log

side note: tsudo doesn't work. ANy command I run with tsudo tells me Permission denied.

  • It tries to create a symlink and fails – as symlinks are not supported by VFAT (internal SD card is presented as VFAT, via FUSE, despite of the underlying system being something else, usually ext4 nowadays). – Izzy May 27 at 5:56
  • does that mean a node based dev environment is going to be impossible without linux/crostini? – The E May 27 at 12:49
  • I cannot tell, I've null experience with NodeJS. That question is better asked in a NodeJS community. One possible solution I could think of is creating e.g. an ext4 volume (on a separate partition of the external card, or in a "container" – I've no idea on details for the latter, though), and locate your NodeJS stuff there. – Izzy May 27 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.