0

I installed Chrooma Keyboard on an Android Nougat device. It worked fine, including swiping to enter text.

After adjusting Chrooma's settings several times, it started to have a problem where keyboard swiping always resulted in an exclamation point instead of a word.

No problem, I thought. I cleared Chrooma's cache and data, and tried it again. The swiping error persisted. I then uninstalled Chrooma, cleaned the device using SD Maid Pro and CCleaner, and rebooted. I thought for sure those steps would clear everything out in order to reset Chrooma to its initial state (and fix the bug).

But alas, even after taking all those steps, the bug in Chrooma (which was not present when it was first installed) persisted. This indicates that it likely wrote some sort of configuration file to a storage location that was not cleared by clearing the app's data and cache, and even by uninstalling it.

Without root privileges, how do you completely delete remnants of an app?

Note: I only use Chrooma Keyboard as an example in this question... the question applies to any app.

  • Most likely the bug was introduced by an update of Chrooma. In such a case nothing you can do will change the situation. Contact the app developer for a fix. – Robert May 28 at 7:01
  • @Robert Thanks for your comment. It all happened within 30 minutes, and there was no update to Chrooma during that time. – RockPaperLizard May 28 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.