I have been trying and failing for days to root my tablet. As far as I can tell there is no TWRP available for this device and the only way that looks possible to root it is to use magisk adb method. The problem is I can't get the root. Img file to allow me to follow the instructions. Can anyone help?



  • Samsung might be tricky to root, read careful (you may need Magisk Canary release): topjohnwu.github.io/Magisk/samsung according to this thread you need to extract it from firmware, which is hard to find: forum.xda-developers.com/showthread.php?t=3887848 few ROMs: support.walytech.com/…
    – alecxs
    Jun 1 '19 at 10:24
  • Thanks for the help with this. I was hoping to do this in the same way as the second thread you posted. I have now managed to extract the boot.img, but when i try to patch it magisk manager says its unknown or an unsupported image. I can extract the .lz4 file from the tar.md5 file easily with 7zip, and lz4.exe appears to extract the .ext4 file with no problems, but when i try to get boot.img from the ext4 file with 7zip it gives a warning saying "there are some data after the payload data". I tried this with 2 different roms that are both for my build number. am i missing something here?
    – Paul
    Jun 6 '19 at 12:09
  • hope this help forum.xda-developers.com/showthread.php?t=2073775
    – alecxs
    Jun 6 '19 at 12:15
  • Thanks again. I can explore the files the files with that tool but still no luck. I found a stock image on desktop.firmware.mobi that magisk manager can patch, but the output is. Img file and there is not option to change the patched file format. Am I missing something or should I try to zip patched boot image up myself and put it back in the apxx.tar.md5 and try to flash that with odin?
    – Paul
    Jun 12 '19 at 18:29
  • the first link is the most important. however, it seems dead, so please read this forum.xda-developers.com/galaxy-s10/development/…
    – alecxs
    Jun 12 '19 at 19:06

Thanks to alecxs for all the help. In the end this was possible with Magisk Manager and odin. I will try and list all the steps needed, but there was a lot of trial and error so I may miss somthing.

  1. Get enable OEM reset then usb debugging (this will factory reset the tablet)
  2. Find the stock boot.img I found mine here
  3. transfer the boot.img to your phone and install magisk manager apk (you will have to enable installing from unknown sources)
  4. click install magisk and choose the option to patch a boot file. Copy the patched file back to your computer
  5. rename the file back to boot.img
  6. download this tool to repackage it to a .tar.md5 file
  7. copy the boot.img into the parts folder and try and make the .tar file then try the .md5. if you have problems download the latest version of cygwin64 and copy the contents from the installation folder into the bin folder of the tar.md5 tool and try again
  8. now you should have a tar.md5 file containing your patched boot.img that you can flash onto the ap partition with odin. restart to boot loader ( hold down power and volume up or use adb command adb reboot-bootloader and flash (there are other more detailed tutorials on how to do this)
  9. check to see if it succeeded. For me it succeeded and then when rebooting it failed the integrity check and factory reset itself. I reinstalled magisk manager and found that it had worked. I let magisk install itself and update. I installed a root checker and it showed i had root access

I hope this helps someone

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.