0

Trying to factory reset my RCA Viking Neptune 10 tablet it has no volume button, no home button, only a power on button and detachable keyboard. Any suggestions are truly appreciated!

  • Do you have a home button? – helper Jun 5 at 13:26
  • Or a pinhole with "reset" printed near it? – helper Jun 5 at 13:29
  • Thank you helper, there is no home button on the tablet. There are some holes on the back of the tablet but none are marked. If I find which one is the reset what would I do please? – Arnie Jun 6 at 6:35
  • 1
    Would reading the user manual tell you this? RCA publishes pdf files for their models. – wbogacz Jun 7 at 22:42
1

As wbogacz suggested i found the user manual and found out that there is a reset button which can be located at number 9 of the following image of the backside of the device:

enter image description here

Press that button to reset the tablet (then press and hold the Power button for 4~5 seconds to turn on the unit).

Hope this solved your query.

  • Thank you so much everyone! It is so strange I tried to press the reset button with a pin and then turn on the power and I still see the same message - "to start android enter your password" How long do you need to press the reset button? Maybe there is something I am missing. Thank you so much!!! – Arnie Jun 10 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.