1

I'm a user of the Realme C2(android P). I've just formatted my SD card as the internal storage through Powershell since my manufacturer doesn't allow me to do it in the settings. It don't think it worked as now i do not see the SD card in the storage section. It seems to have completely disappeared.These are the commands that I used from this link:

adb shell sm list-disk
adb shell sm list-volumes all
adb shell sm set-force-adoptable true
adb shell sm partition disk:179,64 private
adb shell sm set-force-adoptable false
adb shell sm list-volumes all

I really have no idea if they even worked as I was told that the 4th command would take some time but, it didn't. I'll be more than happy to post screenshots or anything that is required for you to understand the problem. So if there is anything you can do to help me, please do so. This is my last resort.

EDIT:

This is what happened in the Powershell window:

PS C:\Users\Sa**vik\Downloads\platform-tools> .\adb devices
List of devices attached
EUS4***ZPBTWAM79 device
PS C:\Users\Sa**vik\Downloads\platform-tools> .\adb shell sm list-disks
disk:1*9:1*8
PS C:\Users\Sa**vik\Downloads\platform-tools> .\adb shell sm list-volumes all
private mounted null
public:1*9:1*0 mounted 01*7-1*13
emulated mounted null

PS C:\Users\Sa**vik\Downloads\platform-tools> .\adb shell sm set-force-adoptable true
PS C:\Users\Sa**vik\Downloads\platform-tools> .\adb shell sm partition disk:1*9,1*8 private
PS C:\Users\Sa**vik\Downloads\platform-tools> .\adb shell sm partition disk:1*9:1*8 private
PS C:\Users\Sa**vik\Downloads\platform-tools> .\adb shell sm set-force-adoptable false
PS C:\Users\Sa**vik\Downloads\platform-tools> .\adb shell sm list-volumes all
emulated:1*9,1*0 unmounted null
private:1*9,1*0 mounted c5ee2ab2-9**7-468e-8**6-c700ba9**283
private mounted null
emulated mounted null
PS C:\Users\Sa**vik\Downloads\platform-tools>

I'd put in * to keep it anonymous

I'm giving up for now. We'll see what happens in the future

2
  • Comments are not for extended discussion; this conversation has been moved to chat. – Andrew T. Jun 9 '19 at 3:52
  • @alecxs the link you gave me doesn't work. I have an issue trying to modify my boot image. It says file image is unsupported – yoloxolo Jun 9 '19 at 12:10
1

When you format your SD card as internal storage (aka ), it will be encrypted. The key for en/decryption is stored on the device only. Hence all that a PC can see is "there is a partition but I don't know what's on it": as it hasn't access to the key, it cannot decrypt the contents.

For further details, see e.g. our adoptable-storage tag-wiki and follow the links from there.

6
  • but that isn't the problem I'm facing! I just can't get the additional memory to show up in my storage settings – yoloxolo Jun 8 '19 at 8:19
  • Could you then please update your question and say so? Even the title suggests you're talking about having formatted the entire card as internal and no wonder where it's gone, and neither does the text speak of "partitioning". Not sure if it's part of the commands used, but then only those familiar with them could spot it. – Izzy Jun 8 '19 at 8:26
  • @Izzy when we talking about adoptable storage issues we should also mention the double encryption problem since Android 9 source.android.com/devices/storage/… – alecxs Jun 8 '19 at 9:19
  • @alecxs only if it's relevant to the problem (it is not here IMHO). – Izzy Jun 8 '19 at 19:38
  • @Izzy Yes the card is gone when we look at the storage from my phone. I don't understand why you thought I was looking at my SD card from a PC. The only thing I used a computer for is to convert my SD card into adaptable storage. Plus I haven't mentioned anything about partition as I didn't to the best of my knowledge make any – yoloxolo Jun 9 '19 at 4:50
-1

Try to plug the memory card into PC and see what is the file system of it. Default format for memory cards is FAT32. Sometimes file systems does gets changed and the changed file system is not compatible with the Android system. It happens a lot of times with USB drives.

4
  • I don't see anything under the file system. Windows thinks the SD card is corrupted – yoloxolo Jun 7 '19 at 15:06
  • thats misleading. (adoptable storage) EXT4 is a linux file system, can't be viewed from Windows directly. However, you can access linux file systems with third party software diskinternals.com/linux-reader – alecxs Jun 7 '19 at 15:27
  • I dont think Android is uses EXT4 file system for external SD Cards. Instead Android Systems use exFAT or FAT32 for the SD cards. all-things-android.com/content/… – michaeljohn22334 Jun 7 '19 at 15:49
  • 1
    Please note that when formatted as internal storage (aka adoptable-storage), the card is encrypted and indeed not formatted FAT but, in most cases, EXT4. – Izzy Jun 8 '19 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.