0

I'm trying to flash LineageOS on a new OnePlus 5T. I have unlocked the bootloader from fastboot, but nothing else is working.

  1. I booted into the stock OnePlus recovery mode and tried to flash LineageOS via adb sideload, but it always failed at 47%.
  2. I tried to flash TWRP 3.2.3-2 and 3.3.0-0, but fastboot flash recovery failed to find the recovery partition.
  3. I tried to flash TWRP 3.3.1-0, and while fastboot said it was successful booting into recovery mode caused the screen to go blank and a blue LED to light up above the screen. No other response.
  4. To fix that I rebooted into the stock ROM, which reinstalls the stock recovery. Because sideloading failed, I tried to enable USB debugging so that I could put the ROM in /sdcard and flash that way. However, despite USB debugging being enabled, the phone never appears in adb devices under any circumstance, so I cannot adb push it.
  5. I read that this can be solved by updating the stock recovery, but because the version number is not displayed I cannot tell if it was actually successful. However, I didn't get any different results after retrying the steps above.

At this point I'm not sure what other options there are for flashing. I've flashed many different ROMs to different models of phone and never seen one so stubborn.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.