0

I recently bought an sd card reader that can be connected via USB-C to a phone.

My phone recognized the SDCard inside that card reader and I can copy files - usually. However, it seems like when I try to copy more than 5 files it will definetly fail and I have to remove the reader, wait a few seconds and connect it again and try again.

I tried two filebrowsers. One came pre-installed with my phone ('Files') and Cx Fileexplorer. The latter seems to have less chance of failing but it will still fail eventually.

Neither of them will give me a proper error message aside from the list of files it couldn't copy.

The copied files were .jpg(5mb on average) and .CR2 ( Canon RAW files which are 22mb on average in size in my case).

Smartphone: Moto Z play, android 8.0.0 stock, not rooted. The SD card is 32 GB in size while my internal microSD is 64gb in size with 40gb free space.

Question would be: How to fix this?

6
  • Does the reader using the same card work without problems on a PC?
    – Robert
    Commented Jun 7, 2019 at 10:57
  • @Robert unknown as the usb-c cable is not detachable. I also haven't tried it on a different smartphone. Commented Jun 7, 2019 at 13:39
  • An SD-card reader with fixed USB-C cable? Can you please edit your question and add the details on the reader (brand, model)? Anyway PCs have USB-C ports, too. I strongly recommend you to test the reader somewhere else and try to use different SD-cards.
    – Robert
    Commented Jun 7, 2019 at 14:37
  • @Robert as I'm currently unable to test the reader on something else I tried a different card - same result - and another file explorer - Total Commander - which seems to work. I copied 200 files at 2.6 GB which worked without issues. Commented Jun 8, 2019 at 7:04
  • @Robert so, I copied files from the SD card via a SD Card reader connected to my computer which worked fine. I also tried a different SD Card with the reader connected to my phone, which resulted in the same problems: The default explorer and the Cx Fileexplorer abort after 4 to 8 files each time, while Total Commander works fine. Commented Jun 12, 2019 at 12:24

0

You must log in to answer this question.

Browse other questions tagged .