0

I have a standard touch keyboard in my Moto Z2 Play (Andriod 8.0 Oreo / Gboard 8.2.11) with two languages: English and Polish.

Whenever I am typing in Polish langauage, I can write nearly a complete garbage and hit space -- in most cases correct word is displayed in bold in the center of suggestion bar, and when I hit space, my "garbage" is correctly replaced.

This looks completely different when I am using English language. Again, my "garbage" is -- in most cases -- recognized into correct word, but it is written in non-bold in suggestion bar and when I hit space, it does not replaces my "garbage". To have correct spelling I must tap center of suggestion bar after each and every space or word written.

I have looked through keyboard settings, but in language-specific settings I can only change keyboard layout and enable or disable multilingual typing.

All other configuration options should be language-independent and work exactly the same no matter which language is being used in Gboard at a given time. Apparently this isn't true.

Is there anything I am missing here? What should I change or do to have auto-correction enabled in each language?

I am using Gboard 8.2.11.248420697-release-armeabi-v7a. In Gboard > Settings > Text Correction I have all but two options enabled. The only disabled settings are Show emoji suggestions and Auto-space after punctiation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.