So I installed a bootanimation on my tablet and it bootlooped because the bootanimation basically crashes the boot sequence

So can I somehow delete bootanimation.zip file? I tried fastboot erase system/media/bootanimation.zip and it says RESULT: FAIL(unable to format) Any help is appreciated

  • boot into custom recovery and delete. provide more information if you want a detailed answer – alecxs Jun 9 '19 at 20:09
  • There's no custom recovery support for the model, not TWRP or CWM. Unofficial versions aren't available either. – Mememan bob Jun 10 '19 at 13:28
  • I guess if it is possible to place a file into /system, it should be possible to port a custom recovery, too. for some devices it is possible to copy partitions from flash tool, manipulate content, and flash it back without data loss. I ask you again, which exact model and android version? Without this information the only answer will be: flash stock ROM. at least you should update your post with steps how you exactly replaced the bootanimation, because you needed root access for this – alecxs Jun 10 '19 at 13:51
  • Please edit your original question and add this information. TWRP is available for your device. forum.xda-developers.com/memo-pad-7/orig-development/… But the tricky part is to unlock bootloader. I guess you can use Intel Flash Tool, but wait for a answer. There is a unlocked bootloader available, i will come back and explain later github.com/me176c-dev/me176c-boot/releases – alecxs Jun 11 '19 at 7:34
  • But I have K013 not ME176C. It's not a correct one, I tried – Mememan Bob Jun 14 '19 at 13:46

Use this temp bootloader to sideload twrp from a PC via fastboot. Can confirm this will work with K013!
Get an SD card format it too EXT2, not anything else. Then use the link below. Now u can back up and thusly manipulate your system partition thru twrp or pull a backup via sdcard and do some magic on the pc with the resulting zip file, repack it ans load the backup. Either way this intel temp recovery thing works on K013 with 4.4.3 kitkat. All the custom recovery that can be actually put on the device require update to 5.0 lolly and above, as this reformats the hidden boot partitions Asus used...the boot is nit normal. Finnally bootanim.zip must be set to be the exact screen resolution the device expects. Can't use just any. https://forum.xda-developers.com/android/development/intel-android-devices-root-temp-cwm-t2975096

| improve this answer | |
New contributor
myname is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

It's Asus Memopad 7 (K013) and I gained root using ZenRoot. I installed bootanimation using Bootanimation changer app. And there's no custom recovery support. Android version is 4.4.4. And I add this here because I can't add comments.

| improve this answer | |
  • You are not able to add comments (or edit within your original post) because you have created a second account with the identical name. Maintenance to your posts cannot happen with a different account. See help regarding merging the accounts you have into the owner account of the original post. – wbogacz Jun 11 '19 at 10:28

Please boot into fastboot from fastboot (yes, this is doubled). Do not flash anything, because the tutorial is for Android 5.

I will update this answer step by step, based on your input
(download link below)

fastboot boot C:\adb\droidboot.img

If this works so far with Android 4.4.4, now enter fastboot mode from the selection screen again. If not, you must flash stock ROM Android 5.0 (or maybe just efilinux.efi + esp.img but this is out of scope, because it may brick your phone)

Now lets see if you can boot TWRP from this. Your bootloader is still locked, so i am not sure if this works.

fastboot boot C:\adb\twrp-recovery-3.3.1-20190609-UNOFFICIAL-me176c.img

in case you get TWRP booting, but it stucks on TWRP splash screen, next check if TWRP's adb is working (at least, this commands can be used on a fully working TWRP too)

adb shell

Now, lets see if TWRP is able to mount /system (within adb shell)

mount /system -w

You should be able to navigate to the bootanimation with cd and check the path. If not, skip this next steps and try to manually mount /system (see last)

Exit the adb shell and replace the bootanimation with the correct one

adb push C:\adb\bootanimation.zip /system/media/bootanimation.zip

If this is successful, set permissions for this file (the last one i am not sure, it is maybe u:object_r:bootanim_exec:s0)

adb shell
chown -h 0.0 /system/media/bootanimation.zip
chmod 0644 /system/media/bootanimation.zip
chcon -h u:object_r:system_file:s0 /system/media/bootanimation.zip  

If this is working without errors, you are done. Reboot your phone with reboot

For manually mount /system in case fstab is wrong, you need to figure out the partition (within adb shell)

ls -l /dev/block/by-name/system
mount -t ext4 -w /dev/block/mmcblk0p* /system

(replace mmcblk0p* with corresponding system partition)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.