I'm following this tutorial about how to unlock bootloader on Moto. My device is a Moto G5, and my computer has windows 10.

On the command line, I can type

adb devices

and it returns my device. I then do

adb reboot bootloader

and it turns my phone into bootloader mode. But when I do

fastboot devices

it returns a blank line. According to this source (the second answer), I need to update some the "Unknown 'Android' device". However, I don't have anything like that. The closest I have is Other devices->Fastboot potter S. Do I update this driver? If so, how? If I choose "Search automatically for updated driver software," it doesn't find anything. If I choose "Browse my computer for driver software" and then "Let me pick from a list of available drivers on my computer", I have to "Select [my] device's type from the list below." but I don't know which one I'm supposed to choose.

How do I fix this problem with fastboot devices? What drivers am I supposed to update? How do I fix them?

If this question is better suited on another stackexchange such as superusers on account of it's being more about windows than android, let me know. I tried asking it there first, but the "android" tag said that the question would be off topic.

  • I did enable usb debugging. I'm not sure about the drivers. I just installed what the tutorial I linked to recommended in the prerequisites. I'll try that later to see if it will work. Jun 11, 2019 at 18:37
  • 2
    USB Debugging is irrelevant within the bootloader. It does its thing within the system and recovery. This might help with the drivers: support.motorola.com/in/en/solution/MS89880#
    – Bo Lawson
    Jun 12, 2019 at 17:41

1 Answer 1


Got stuck at the exact same point when I had this problem! I figured out I could follow the instructions on this page (https://developer.android.com/studio/run/oem-usb), and once I downloaded and installed the right driver, the device showed up when I ran

fastboot devices -l

then I just did fastboot reboot and everything worked : )

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .