0

I can't seem to get any applications to start at boot. I wanted sshd to run at startup so I installed "Termux", "Termux:Api" and "Termux:Boot" and followed the instructions and placed the startup scripts in $HOME/.termux/boot. I checked the logs and there were no errors but no mention of startup scripts being initiated and on boot Termux:Boot was not started.

Thinking this might be a bug in Termux(since I was using an older version as they have removed features in the newer versions to comply with Google Play policies) I installed "Automate" app and created a simple flow which just turns on the wifi hotspot when it receives the broadcast "BOOT_COMPLETED" but it never receives the broadcast(as shown in the logs). I tried changing the broadcast event from BOOT_COMPLETED to SERVICE_STARTED (Automate service, which in settings is selected to start automatically) but that too only starts once I open the App manually.

The phone is Lava Z60, stock ROM, not rooted although I tried to but I can't enter the fastboot mode. The phone shuts down when I try to enter fastboot mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.