I've been fruitlessly trying to get the new Android OS update for my s2 for quite some time now and I finally thought my troubles were over when I saw an update for Samsung Kies pop up earlier today but now I'm just even more confused. Before there just wasn't an option to update (the update button was greyed out) but now the firmware update and initialisation button is no longer grey but comes up with the error notice:

GT-I9100 does not support initialising

What does this mean? I've spent quite a long time trawling through internet forums trying to find my answer to no avail; it seems no one out there has my problem. What does this error mean? Am I unable to update at all?

  • I've had and heard of plenty of strange Kies problems. First, the basics; did you try 1) restarting your phone, 2) restarting your computer, and 3) reinstalling Kies?
    – Mr. Buster
    Commented Apr 4, 2012 at 23:27
  • Which update? Can you be specific? (Help out future readers, eh?)
    – ale
    Commented May 9, 2012 at 13:23

6 Answers 6


Yesterday I had the "firmware upgrade" button available and working (begins to download upgrade components etc) but my internet was playing up, so I tried again today and all of a sudden Kies was telling me "'GT-I9100T' does not support initialisation" (and upgrade component downloading window did not appear).

As suggested by Sparx, I checked my debugging setting. It was already unchecked, BUT I found that when I checked it, then unchecked it (the phone will prompt you to remove USB cable before you can toggle this option) it restored the "firmware upgrade" button.

Frustrations which remain:

  1. The process began again but stopped half way through, telling me that "phone battery is low, charge phone battery" (phone was plugged in via USB and charging already from computer). When I clicked OK, the process aborted and I am back at the Kies screen without a "firmware upgrade" button again (so will have to toggle the debugging option again - annoying, but faster than rebooting computer and/or phone).

  2. Kies doesn't tell you the download size - I have dialup broadband with a small bandwidth allowance and cannot afford to be downloading excessive amounts. It would be really helpful if we could discover the sizes of these upgrade downloads.

  3. Kies re-downloads firmware update process files (the ones before it starts downloading the actual upgrade files) each time I attempt to upgrade firmware - even if this was done 1 minute ago. I would think Samsung would have the programming prowess by now to cache these files rather than re-download them (for me, this also relates to issue #2).

I hope this helps others.


For comparison I set up a VM of windows xp 32 bit and installed kies, it recognized the firmware without issue (both an ACE2 and a Galaxy S3), kies on win 8 64 bit tells me both phones do not support initialization and the firmware cannot be upgraded (despite repeated re-installs and troubleshooting) !?!

My feeling from reading other posts and the above is KIES has problems with 64 bit environments


Also, make sure USB debugging is set to off. Find it in settings > Applications > Development


I was having the same issue, download the latest version of Kies (from the Samung website) and then retry.

This worked for me


This is the same situation as my own S2, I think that option becoming available is simply a bug in the latest Kies update. In all probability the Android 4.0 update (I assume) you are waiting on has not been released for you version of the handset yet.


On the same day you were having the problem mentioned on your question, a CNET article was being published covering the reason as to why you have the update option available but can't just wet perform the update.

Essentially, you'll be getting that message while operators are finishing tests to the update package, in order to make sure everything will work properly, as mentioned by Simon Stanford, VP of Samsung Telecommunications and Networks for Samsung UK and Ireland, speaking exclusively to CNET UK:

Galaxy S2 SIM-free owners last to get ICS, Samsung admits

Additionally, this is covered at Vodafone forums, and linked on page 15.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .