1

I have an old Samsung Galaxy S3 that's been sitting in my desk for years. I wanted to clear it off to give to a friend, but I'm not seeing the factory reset option anywhere. All guides I can find online indicate that it should be in the Settings app, but it's not. (There is no Privacy section anywhere in the Settings app.)

Is there any other way to factory-reset a phone? It's on 4.3 (Jellybean), according to the About Device screen. (I've tried to get to recovery mode with the power/volume down key trick, but it doesn't work; just continues to boot normally.)

  • 1
    Tried this recovery approach? – Andy Yan Jun 19 at 3:55
  • As Andy Yan already figured out, you just forgot the Home Button, its 3x Buttons for Samsung – alecxs Jun 19 at 19:12
  • 1
    Yes, @AndyYan - I had tried that as well, and it didn't work. I did figure out the issue, and posted as an answer in case anyone else runs into this. – EmmyS Jun 22 at 2:25
1

Posting this as answer in case anyone else runs into this.

It turns out that I had manually disconnected my Google account years ago, when I switched to a new phone. By reconnecting the Google account, it added the Privacy section (including the Factory Reset option) back into the Settings app. Once that option became available again, the reset worked with no problem.

0

If you can't go to Recovery Mode, hence go to download mode and use Odin to flash your android device.

  1. Reboot Phone and go to Download Mode. (press and hold Home + Power + Volume Down buttons)
  2. Connect your android device to PC and wait until you get a blue sign in Odin.
  3. Download a good verion of framework which is match with your device (build number, etc).
  4. Add the downloaded firmware file to AP / PDA in Odin.
  5. Make sure re-partition is NOT ticked.
  6. Click the start button and wait few minutes.
  7. After step 6, your phone will start, but it takes a few minuets at first time turing on.
  • for a simple reset, really? – alecxs Jun 19 at 19:06
  • OK, that's kind of overkill, plus, I couldn't get into download mode either. – EmmyS Jun 22 at 2:25
  • Unfortunately, you have to change the internal storage chip. – M. Rostami Jun 22 at 4:41
  • @alecxs Yes, It's for a device which can't run recovery mode. – M. Rostami Jun 22 at 4:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.