0

I bought a Samsung Galaxy S6 in Aug 2016. Everything was fine, until last week. It got very slow. For example, when I draw my unlock pattern after a reboot, it takes such a long time to load the homescreen that the screen turns off. After a few tries, I get in but every tap takes very long until the device reacts. It takes ~25 seconds just to load the keyboard.

I downloaded System Monitor but the CPU load was not on 100%, so there is no app/virus which consumes too much CPU time. Geekbench 4 says that the CPU / GPU performance is even above average for the Galaxy S6.

But then I decided to test the storage speed. I ran Androbench and the results are very bad (see screenshot). Screenshot of Androbench

Normally, the performance should be like in this test.

So my questions now are: how can I find out why is the storage so slow? Is it just flash wear? Is is a broken driver? If it's a hardware failure, what part do I have to replace?

If something is unclear, just comment and I will edit the question. Thank you in advance!

UPDATE 2019/06/20 08:03: Tried reflashing the stock firmware and factory reset, but it didn't helped. The benchmark is even worse now. Ordered a new motherboard now.

UPDATE 2019/08/19 09:57: New motherboard finally arrived. After changing it, everything was fine. Problem solved.

  • Perform a full factory reset and retest with no setup or other apps installed... Either it will correct the problem or it will verify your internal storage is starting to fail (call it Flash Wear or whatever you wish, it's a hardware failure, just not a critical stop one, but it will be eventually). It is not likely a driver issue, that is a base kernel module, and lots of others would have noted it in the past, but this device has no history of that. – acejavelin Jun 19 at 11:27
  • Check the device for malware running in background and remove it. – Robert Jun 19 at 13:06
0

I'm getting 45 MB/s sequential write when it should be 120 MB/s. Read speeds are roughly the same as on the review though.

In your case, I would try full factory reset, reflashing the stock ROM or even a custom ROM with a different kernel to see if the benchmark would generate different results. If you get roughly the same results after all, it's a hardware problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.