1

I got a new Pixel 2 and wanted to load an TWRP backup from my previous Pixel 2 (with stock ROM) onto it, instead of setting it up freshly. So I

  • booted the new device
  • clicked through the settings
  • entered developer mode and oem unlock
  • rebooted
  • unlocked the bootloader
  • booted into TWRP (using fastboot boot)
  • copied my old /sdcard contents to the device using adb
  • used TWRP to restore the old backup (partitions boot, system and data.

At that point I hoped I was done, and could just boot into my system. But unfortunately, it always just boots into the bootloader.

What did I do wrong?

And what do I do now?

  • I tried to do a factory reset by using fastboot flashing lock, and it claimed it would reset the phone, but it doesn’t.
  • I tried to enter recovery from the bootloader, but it just boots into the bootloader.
  • I tried to flash an official image from https://developers.google.com/android/images#walleye using ./flash-all.sh but it fails to update the bootloader:

    Sending 'bootloader_a' (38692 KB)                  OKAY [0.155s]
    Writing 'bootloader_a'                             (bootloader) Updating: partition:0   @00002000 sz=0000B000
    FAILED (remote: 'Command Flash Error')
    fastboot: error: Command failed
    

    and then fails do do more:

    --------------------------------------------
    Bootloader Version...: mw8998-002.0059.00
    Baseband Version.....: g8998-00008-1902121845
    Serial Number........: …
    --------------------------------------------
    extracting android-info.txt (0 MB) to RAM...
    Checking 'product'                                 OKAY [0.000s]
    Checking 'version-bootloader'                      FAILED
    
    Device version-bootloader is 'mw8998-002.0059.00'.
    Update requires 'mw8998-002.0076.00'.
    
    fastboot: error: requirements not met!
    
  • I tried to boot twrp again, but that does not work:

    $ fastboot boot twrp-3.3.0-0-walleye.img 
    downloading 'boot.img'...
    OKAY [  0.115s]
    booting...
    FAILED (remote: Failed to load/authenticate boot image: Load Error)
    

What else should I try?

0

It seems that the script at https://forum.xda-developers.com/pixel-2-xl/development/tool-deuces-bootloop-recovery-flashing-t3704761 was able to apply a system update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.