1

I have a Hyundai Orbit android phone. The situation is as follows:

  1. The phone has a pin which we don't know
  2. The phone was never signed into any google or other accounts
  3. USB debugging is not turned on
  4. We have tried starting the phone while holding all combinations of buttons and it always just boots normally, never into fastboot/recovery mode. We have been able to boot with "Safe mode" in the bottom right hand corner of the screen

Is there any way to do a factory reset under these conditions?

  • i cannot believe that fastboot is not reachable. Anyway, last (and most awkward) option is SP Flash Tool. You don't have stock ROM, and you don't have scatter file. So you must perform memory test to get size, then you can create a full ROM dump. From this ROM dump, you can create a scatter file with WwR MTK v2.50. from this scatter file, you can use the start address and size of userdata partition, and format this area of the memory from SP Flash Tool. All this can be done off (without battery) with VCOM Preloader drivers, no button is needed. I won't give detailed instruction, request a link – alecxs Jun 22 at 22:12
  • @alecxs Can you please give me the link with instructions? I have SP flash tools working, but I'm not sure how to interpret the memory test output. – user1373823 Jun 23 at 5:22
  • forum.xda-developers.com/apps/magisk/… don't do this unless you have splitted the ROM dump (for backup purposes in case something get wrong) forum.hovatek.com/thread-21638.html please note, this erases the partition. Maybe you must flash a empty ext4 partition image with exact same size (you need linux for creating) – alecxs Jun 23 at 7:55
  • So you think just erasing the user partition might make the phone unbootable? Do you know that or is it just a guess? Maybe android would rebuild the partition after erasing and then booting? – user1373823 Jun 23 at 9:23
  • i know it is unbootable when erasing cache partition. in case of userdata it may bring you to recovery, which then automatically recreates the partition - just a guess. but not a big deal, you can create userdata ext4 image with dd + mke2fs / anyway i would give a try what @Ezekiel answered, first! – alecxs Jun 23 at 9:25
1

Some phone needs to be plugged to light before it can boot to recovery mode/hard reset. Try putting the plugged charger in the phone when it's switched off and immediately it shows the charging signal press the volume down⬇key+power key, if that doesn't work try volume up⬆key+power key. The both work for my phone innjoo i2s.

  • I tried this and it didn't work. – user1373823 Jun 23 at 5:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.